Jump to content

MyGica_1900AC/1800/582/380_Android_5.1_20170612 1.0.0

   (7 reviews)

1 Screenshot

About This File

Here is the Beta Firmware to upgrade your ATV 1900AC/1800 series/582/380 to Android 5.1

You can install this using an SD Card or USB drive and the upgrade app listed in the settings area.

This does not require manually pressing the reset button.

Just extract the IMG file from the zip folder and move it to a USB drive or SD Card that is formatted to FAT32.

**PLEASE NOTE THIS WILL FACTORY RESET YOUR DEVICE**

 

Change Logs:

1. Updated to KODI 17.3
2. Updated Google Play Services
3. Faster Performance 
4. Fixed Mac Address changing 
5. Turned off click sounds when browsing through the Home Screen + Android Settings
6. Fixed Screensaver issue when watching a video
7. Improved video playback
8. Improved standby issues as best we could. There is not much more we can do about this issue

 

 

-----------------------------------------

Mygica is not responsible for damage to the unit outside of the 1 year warranty period.

----------------------------------------




User Feedback

Recommended Comments



Good day.

After downloading this latest Beta version "MyGica_1900AC/1800/582/380_Android_5.1_20170612 1.0.0" as you recommended, and installed it on my 1800e. Every thing works perfectly.

However, when it came to install 'EDITED BY JUSTIN, WE DONT POST THIRD PARTY LINKS', an error message popped up said that it cannot connect to the host server. But, I saved it any way. Hence, I enabled 'Unknown Source' in order to install third party apt. Next, I tried to install a couple of addons zip files in the 'Fusion' folder. But, no matter how many times I clicked on the 'Fusion' folder, it did not open up the folder, and finally, another error message came up saying that "it cannot connect to the server"????.

Is there any suggestions to fix the connection to the host server issue? It seems that I cannot install anything in Kodi Krypton 17.3 which came with the install package.

Regards

Share this comment


Link to comment
Share on other sites
18 hours ago, dxn131 said:

Good day.

After downloading this latest Beta version "MyGica_1900AC/1800/582/380_Android_5.1_20170612 1.0.0" as you recommended, and installed it on my 1800e. Every thing works perfectly.

However, when it came to install 'EDITED BY JUSTIN, WE DONT POST THIRD PARTY LINKS', an error message popped up said that it cannot connect to the host server. But, I saved it any way. Hence, I enabled 'Unknown Source' in order to install third party apt. Next, I tried to install a couple of addons zip files in the 'Fusion' folder. But, no matter how many times I clicked on the 'Fusion' folder, it did not open up the folder, and finally, another error message came up saying that "it cannot connect to the server"????.

Is there any suggestions to fix the connection to the host server issue? It seems that I cannot install anything in Kodi Krypton 17.3 which came with the install package.

Regards

When you get a message like "Cannot connect to the host server" it generally means that URL does not work or exist.

Try typing the same URL into your web browser on your computer or phone, you will see what I mean.

Share this comment


Link to comment
Share on other sites

@Justin, curious if this version with Kodi 17.3 has the audio passthrough fixed in it?  Currently I use Kodi 16.1 and MyGica Media Center 17.0, but the passthrough for local files when they have DTS or 5.1 audio only properly works on Kodi 16.1.  It would just keep switching back and forth every second on anything 17+ that I tried previously.  My understanding was that this was something to do with the Android audio APIs needing to be updated.

Unit is 1800E.

Edited by PhoenixIce

Share this comment


Link to comment
Share on other sites

I have downloaded and installed this version (5.1) on my 582. I found that the system ran very slowly and could sometimes waiting up to a couple minutes when switching from one app to another one.  Is there any way I could revert back to the previous version?  I have tried downloading the factory kitkat version into a micro SD card and put it into the 582 box and reboot. I then used the software update app and tried Local update to select the file from SD but I could not see the file at all.  I tried this many times and still could not see the firmware file.  

Please suggest a solution. Thanks.

Share this comment


Link to comment
Share on other sites
On 7/12/2017 at 0:55 AM, PhoenixIce said:

@Justin, curious if this version with Kodi 17.3 has the audio passthrough fixed in it?  Currently I use Kodi 16.1 and MyGica Media Center 17.0, but the passthrough for local files when they have DTS or 5.1 audio only properly works on Kodi 16.1.  It would just keep switching back and forth every second on anything 17+ that I tried previously.  My understanding was that this was something to do with the Android audio APIs needing to be updated.

Unit is 1800E.

If the issue is due to Android audio apis needing to be updated, then we wont be able to fix that
Amlogic no longer supports the SDK for the version of Android 5.1 for the S805/S812/S802 chipsets.

Share this comment


Link to comment
Share on other sites
On 7/19/2017 at 0:13 AM, csho88 said:

I have downloaded and installed this version (5.1) on my 582. I found that the system ran very slowly and could sometimes waiting up to a couple minutes when switching from one app to another one.  Is there any way I could revert back to the previous version?  I have tried downloading the factory kitkat version into a micro SD card and put it into the 582 box and reboot. I then used the software update app and tried Local update to select the file from SD but I could not see the file at all.  I tried this many times and still could not see the firmware file.  

Please suggest a solution. Thanks.

When in local update

Press the 3 lined menu button 10+ times and the file will appear.
I am not 100% sure you can downgrade to 4.4 this way though

I would suggest the factory files instead.

 

Share this comment


Link to comment
Share on other sites

I installed this on an ATV380 two weeks ago now.

Kodi's GUI is responsive but playback is inconsistent - it either lags and/or skips and/or freezes for a few seconds 3 to 5. I have that on movies on remote CIFS, streams for an HDhomerun box on the same LAN which has been working fine for a long time and other sources as well. There is no issue with these sources on a traditional PC running Kodi.

It is not unusable but it feels like something, somewhere is under specs for Kodi 17 as a player.

Netflix works fine so as youtube.

I was wondering what is missing for you to release this and whether 5.5.1 will be the last release or whether a 6.0 could work.

Anything I should do to help troubleshoot?

Share this comment


Link to comment
Share on other sites

I have read a couple of others' issue reports and based on my past experience I went through to find the solution. I would recommend to bring up CWM (Clock Work Mode) menu, and try to CLEAR SYSTEM CACHE before you can install/upgrafe Lollilop 5.11. I always do this every time and I don't have a problem.

  • Like 1

Share this comment


Link to comment
Share on other sites
16 hours ago, Roger Simpson said:

I installed this on an ATV380 two weeks ago now.

Kodi's GUI is responsive but playback is inconsistent - it either lags and/or skips and/or freezes for a few seconds 3 to 5. I have that on movies on remote CIFS, streams for an HDhomerun box on the same LAN which has been working fine for a long time and other sources as well. There is no issue with these sources on a traditional PC running Kodi.

It is not unusable but it feels like something, somewhere is under specs for Kodi 17 as a player.

Netflix works fine so as youtube.

I was wondering what is missing for you to release this and whether 5.5.1 will be the last release or whether a 6.0 could work.

Anything I should do to help troubleshoot?

Not sure what you mean by what is missing?

This will more then likely be the last 5.1 release for all of our old models
We will fix the coming of out standby wifi issue, but that will probably be the last update to the firmware we released last month.

Android 6 will never be available for these models, as AMlogic ended support for the S805/S802/S812 Chipsets at Android 5.1

Share this comment


Link to comment
Share on other sites
3 hours ago, Justin said:

Not sure what you mean by what is missing?

This will more then likely be the last 5.1 release for all of our old models
We will fix the coming of out standby wifi issue, but that will probably be the last update to the firmware we released last month.

Android 6 will never be available for these models, as AMlogic ended support for the S805/S802/S812 Chipsets at Android 5.1

I was just wondering if I forgot to do something.

Your statement that Android 6 is never going to be available is what I was looking for. The lifecycle of these is quite short.

Share this comment


Link to comment
Share on other sites
16 hours ago, Roger Simpson said:

I was just wondering if I forgot to do something.

Your statement that Android 6 is never going to be available is what I was looking for. The lifecycle of these is quite short.

The S802 + S805 and S812 came out in 2014 from Amlogic.

They generally start with one OS, in this case was Android 4.4 and do one OS upgrade, which in this case was 5.1 with an Alpha version of 5.0 as well, but they moved to 5.1 since it worked out a lot of bugs.


If you are using Android for a set top box, there is almost no difference between Android 5.1 and 6.0 in terms of the changelist.
Majority of the changes were for Mobile phones.

Share this comment


Link to comment
Share on other sites
On 7/25/2017 at 11:59 AM, Justin said:

The S802 + S805 and S812 came out in 2014 from Amlogic.

They generally start with one OS, in this case was Android 4.4 and do one OS upgrade, which in this case was 5.1 with an Alpha version of 5.0 as well, but they moved to 5.1 since it worked out a lot of bugs.


If you are using Android for a set top box, there is almost no difference between Android 5.1 and 6.0 in terms of the changelist.
Majority of the changes were for Mobile phones.

Netflix glitches every few seconds and no wifi has definitely got to be fixed.  Also to stop support of a 3-year-old box is not acceptable for $200 premium box if you guys want people to purchase your products you have to do better at addressing software issues or you will go the way of the DODO bird.

Share this comment


Link to comment
Share on other sites
6 hours ago, nonothing said:

Netflix glitches every few seconds and no wifi has definitely got to be fixed.  Also to stop support of a 3-year-old box is not acceptable for $200 premium box if you guys want people to purchase your products you have to do better at addressing software issues or you will go the way of the DODO bird.

Wifi coming out of standby we are testing a fix for it now.
Once ready, we will release it.

Netflix we currently cannot reproduce it, so will continue to try.


And we haven't stopped support, we have just stopped it at Android 5.1 since we cannot go to a newer Android version since its not possible.

Share this comment


Link to comment
Share on other sites

Hi  Justin, I just want to confirm, this beta Lollipop , is it also for 582?  My is unrooted because I needed for some paid services to work..

If II upgrade to 5.1 is it still gona be Unrooted?

 

Thanks

Nick

 

Share this comment


Link to comment
Share on other sites

Hi 

I have upgraded the firmware on my 1800e to Android_5.1_20170612 1.0.0.

But now I have an issue where my 1800e when turned on Freezes on the "Mygica "logo when starting up. It takes up to 3-5 unplugging of the power and eventually it will boot up.

But once booted up it will work for about 10min and the freeze and I have to plug the power out again and reboot. 

I am using Ethernet cable to connect to internet and have wifi turned off.

Any suggestions ? 

 

Thanks

Share this comment


Link to comment
Share on other sites
On 8/22/2017 at 4:27 PM, supafly_mx said:

Hi 

I have upgraded the firmware on my 1800e to Android_5.1_20170612 1.0.0.

But now I have an issue where my 1800e when turned on Freezes on the "Mygica "logo when starting up. It takes up to 3-5 unplugging of the power and eventually it will boot up.

But once booted up it will work for about 10min and the freeze and I have to plug the power out again and reboot. 

I am using Ethernet cable to connect to internet and have wifi turned off.

Any suggestions ? 

 

Thanks

 

Exactly same issue with my ATV380 - given the system seems to be close to retirement I did not bother trying to reset the box. It is currently looking like bricked since it does not boot anymore (stuck on the Mygica logo for ages) I decided to go with a slightly beefier alternative from a brand doing graphic cards ;-)

Will try whenever a new version is released for the ATV380 but for now it is a beta and not as stable as one would like for that kind of device

 

Share this comment


Link to comment
Share on other sites

Hi,

I have huge problems upgrading with this file <Mygica_1900AC/1800/5892/380_Android_5-1_20170612 1.0.0>.For starters, it takes a heck of a long time to boot up. It gets stuck at Mygica - Seeing is Believing screen for a longtime (can be as long as 10 minutes) before booting up. Once in, it does have a fresh 'feeling' to it. Kudos to the guys who made this upgrade.

However, unit hangups are common. I used SSH and it hangs during transmission of files. Literally, one has to physically reboot the 1800E unit, twice at least and wait between 5 to 10 minutes before it is fully operational. Inside Kodi, it hangs when trying to install simple things like metadata information addons.  This literally prevent it to from being a reliable unit.

But I like the feel of android 5.1 and I would like to use it for my daily needs. I am not sure if this is a problem with the Upgrade process. Would it be possible for you to package the upgrade as a recovery format, meaning we have to boot into recovery in order to update as against the present method of upgrading from inside the android os. The format I speak of is the same as the ATV1800E-Factory-Files.zip file.

Alternatively, I have downloaded two files from your site and would like to try them out.

update_MyGica_ATV1900AC_5.1_noNetflixHD_20160706.img & update_Mygica_ATV1900AC_5.1_NoNetflixHD_20161121.img

Which file would be suitable for the 1800E unit?

 

Share this comment


Link to comment
Share on other sites

@Justin I want to give it a last try to recover my ATV1800E box.

I have downloaded the Amlogic usb burning tool and I can connect and see the box by using an old cable but whenever I try to load an image file into the burning tool I get a "parse Burning image fail"

Is there a different .img file that I need to load in the burning tool? I have tried all the SD img files and I always get the same error.

Thanks.
 

Share this comment


Link to comment
Share on other sites
On 8/28/2017 at 10:09 PM, omnivassal said:

Hi,

I have huge problems upgrading with this file <Mygica_1900AC/1800/5892/380_Android_5-1_20170612 1.0.0>.For starters, it takes a heck of a long time to boot up. It gets stuck at Mygica - Seeing is Believing screen for a longtime (can be as long as 10 minutes) before booting up. Once in, it does have a fresh 'feeling' to it. Kudos to the guys who made this upgrade.

However, unit hangups are common. I used SSH and it hangs during transmission of files. Literally, one has to physically reboot the 1800E unit, twice at least and wait between 5 to 10 minutes before it is fully operational. Inside Kodi, it hangs when trying to install simple things like metadata information addons.  This literally prevent it to from being a reliable unit.

But I like the feel of android 5.1 and I would like to use it for my daily needs. I am not sure if this is a problem with the Upgrade process. Would it be possible for you to package the upgrade as a recovery format, meaning we have to boot into recovery in order to update as against the present method of upgrading from inside the android os. The format I speak of is the same as the ATV1800E-Factory-Files.zip file.

Alternatively, I have downloaded two files from your site and would like to try them out.

update_MyGica_ATV1900AC_5.1_noNetflixHD_20160706.img & update_Mygica_ATV1900AC_5.1_NoNetflixHD_20161121.img

Which file would be suitable for the 1800E unit?

 

You can upgrade in Recovery mode using the same files as you would in the Android OS
This is actually one of the only ways that I upgrade all of my units, unless a bootcard is needed.

Share this comment


Link to comment
Share on other sites
3 minutes ago, munecito said:

@Justin I want to give it a last try to recover my ATV1800E box.

I have downloaded the Amlogic usb burning tool and I can connect and see the box by using an old cable but whenever I try to load an image file into the burning tool I get a "parse Burning image fail"

Is there a different .img file that I need to load in the burning tool? I have tried all the SD img files and I always get the same error.

Thanks.
 

I found out we do not support the USB Burning tool from Amlogic

I will see if another method is available

Share this comment


Link to comment
Share on other sites
5 minutes ago, Justin said:

I found out we do not support the USB Burning tool from Amlogic

I will see if another method is available

Thank you very much. I am really trying to save this box, but I am afraid that I am not going to win this one.

 

Share this comment


Link to comment
Share on other sites
30 minutes ago, munecito said:

Thank you very much. I am really trying to save this box, but I am afraid that I am not going to win this one.

 

If you live in Canada, our office is here
You can always send it to us to have 5.1 installed

Share this comment


Link to comment
Share on other sites

After reading the comments I am having second thoughts about upgrading my 1800E I have 2 and updated 1 with the first beta release with the 2 files. 

I am intrigued by the reply to the comment above.

@Justin - Where in Canada do we send our boxes for the 5.1 upgrade and what is the cost? 

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×