Jump to content

Recommended Posts

Hello, guys. I will join the party of those, who not really happy with the quality of the product. 

My problems are:

- Hd cap X not recording the component signal

- It seems it does capturing the HDMI/Composite signal in most of the cases, though quality is not perfect here

- Also - it does not start recording the Playstation 3 HDMI input

 

My questions:

1) What is the latest firmware available

 for this device

2) How can i check current version if firmware on my device?

3) And for real...do you plan to support this device at all?

 

Share this post


Link to post
Share on other sites

Hello friend, I also want the latest firmware for this card.

The support appears to don't care anymore about their users.

I'm so sad about this card, no good video quality when recording like 10mbit of video bitrate os crappy aofr 1080p resolution.,..

Share this post


Link to post
Share on other sites
7 hours ago, Denys said:

Hello, guys. I will join the party of those, who not really happy with the quality of the product. 

My problems are:

- Hd cap X not recording the component signal

- It seems it does capturing the HDMI/Composite signal in most of the cases, though quality is not perfect here

- Also - it does not start recording the Playstation 3 HDMI input

 

My questions:

1) What is the latest firmware available

 for this device

2) How can i check current version if firmware on my device?

3) And for real...do you plan to support this device at all?

 

 

Just now, Rafael Fongozi said:

Hello friend, I also want the latest firmware for this card.

The support appears to don't care anymore about their users.

I'm so sad about this card, no good video quality when recording like 10mbit of video bitrate os crappy aofr 1080p resolution.,..

 

Wait for mygica support on this!

Share this post


Link to post
Share on other sites
20 hours ago, zxl said:

Hi,

Sorry for the late reply.

Please try this link to download the firmware you need:

https://mega.nz/#!z91yTL5R!6Ff-qjMn4ojctwTLQGv6gPJw0TqxnbiVq3ZrQ3-heJo

 

zxl, many thanks. It seems indeed solved almost all of my problems with the device. Every source i tried now can be recorded and even recording quality is improved. If anything i noticed some issues with my PS3 recording, sound was captured with some noises, though after i turned off multichannel output on PS3 this problem also dissapeared. I wonder why not put this firmware in download section, is it still beta or something? 

Anyway - this firmware indeed solves many issues we encountered with HD Cap X, so i recommend to try it, guys.

Share this post


Link to post
Share on other sites
On Thu Jul 06 2017 at 5:57 AM, Denys said:

zxl, many thanks. It seems indeed solved almost all of my problems with the device. Every source i tried now can be recorded and even recording quality is improved. If anything i noticed some issues with my PS3 recording, sound was captured with some noises, though after i turned off multichannel output on PS3 this problem also dissapeared. I wonder why not put this firmware in download section, is it still beta or something? 

Anyway - this firmware indeed solves many issues we encountered with HD Cap X, so i recommend to try it, guys.

Hi,

We are happy to hear that your problem can be solved and it is developed and not a beta version.

Share this post


Link to post
Share on other sites
On Thu Jul 06 2017 at 7:18 AM, fer424 said:

Hi zxl, do you know if this new firmware allows to input  video format PAL in the CVBS in? Thanks

Hi,

It allows to input  video format PAL in the CVBS inallows to input  video format PAL in the CVBS in as you want.

Share this post


Link to post
Share on other sites

Hi zxl

The problem is very simple, I have a PAL composite video signal which  is not detected by the HD CAP X, the signal go to the yellow port but the yellow led in the HD CAP X stays blinking all the time. I have not problem with a composite NTSC signal, the led go steady yellow and the capturer works fine but not work with a pal signal.

 

Edited by arturojgt

Share this post


Link to post
Share on other sites
On 27/6/2017 at 12:39 AM, fer424 said:

Good morning, there exists some firmware that allows to input  video format PAL in the CVBS in?

My HD Cap accepts any format entering trough HDMI or YPbPr, but if revenue PAL format trough CVBS, records it in black and white (with NTSC works fine). And my equipments have exits only PAL  (I am in Argentina). Thanks for any reply

Argentina uses PAL-N and the original PAL is PAL-B. You need a PAL B-N Trascoder to have color input. Or Mygica must to write a new firmware for PAL-N.

Argentina usa PAL-N y el PAL original es el PAL-B. Necesitas un trascodificador PAL B-N para tener imagen a color. O Mygica debe escribir un nuevo firmware para PAL-N.

Regards.

Share this post


Link to post
Share on other sites

 

I had this problem before and I received an e-mail file sent by MyGica. I received instructions to place the file in the root of the flash drive, connect the power and wait for the update. Was solved. I do not have the update file.

Share this post


Link to post
Share on other sites
5 hours ago, uumax said:

 

I had this problem before and I received an e-mail file sent by MyGica. I received instructions to place the file in the root of the flash drive, connect the power and wait for the update. Was solved. I do not have the update file.

Can you look into your email?, maybe is there buried.

Share this post


Link to post
Share on other sites

HD Cap X firmware: https://mega.nz/#!ai5BSLKI!jbu4oKJRj2yorwWFCPoHz6zQZgaH7Zl2iAC3aMpVzGs

Instructions:

Ø The jedi.img files are copied to the root directory of U disk

 Ø The U disk is inserted into the USB interface of HD Cap X

 Ø Re plug the power, the system will automatically find the upgrade file to update the firmware

Ø During the upgrade process, Rec LED will flash 3-5 seconds, after the upgrade is complete, the system will automatically restart

Ø The system firmware upgrade is complete U disk jedi.img will automatically delete.

 

Share this post


Link to post
Share on other sites

Hi, My HD Cap X not working! please help. I'm using windows 10 (1903) but the record button not working (the light is off), what is wrong? It was working before, in windows 10 (1809).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...