MyGica Support

1900AC/1800E 5.1 Firmware November 23 2016

344 posts in this topic

Here is Manual Update File for ATV 1900AC and 1800E  for Android 5.1

**This is the official release and no longer in Beta**

We have been testing this all week and last weekend. Please leave comments and feedback below. This should solve lots of issues you guys have been having.

To use the updater app, just download the  .img file and load it onto a usb or SD card.

**ALSO IF USING THE UPGRADE APP, MAKE SURE TO PRESS THE 3 LINED CONTEXT MENU BUTTON ON THE REMOTE CONTROL 10+ TIMES. THE FILE WILL APPEAR AFTER DOING THIS**

To do a full manual install or to fix problematic boxes, use the zip folder.

You must extract the all the Files from the Zip Folder.

You can load it onto the box using Micro SD. Hold down the reset button once the SD card is installed and plug in the power cord. Continue holding down the reset button until you see the front lights flash between green and red. From this point just leave it for about 10 minutes.

**THIS WILL FACTORY RESET YOUR BOX**

***CHANGES***

1.  voice search re-enabled. (You must install Google Now from the Playstore and enable it within Android settings under Language and Input settings menu)
2. power on/off issue fixed 
3. Memory Clean and Power Icons added to launcher
4. KODI 16.1 pre installed
5. You tube app updated

6.  Pre-Installed Facebook and Netflix apps need to be updated after logging into the Play Store
7.  Updated to latest Google Play Services now with Google Smart Lock
8. Home Screen Menu/Launcher now supports 24H and 12H Time

1900_factory_restore.rar

update_Mygica_ATV1900AC_5.1_NoNetflixHD_20161121.img

Edited by Justin
To put that 1800E will work
1 person likes this

Share this post


Link to post
Share on other sites

Thank you to the MyGica support team on coming through as promised. Let's hope we are done with "testing" the 1900 and on with "using" it.  I won't get to installIng this until tomorrow  night at the earliest and will share my results but in the meantime I'm looking  forward to seeing everyone's experiences.

They came through, let's hope they delivered!

1 person likes this

Share this post


Link to post
Share on other sites

when will we be getting the update for the atv582, I have another android box t95x and it runs android 6.0 flawlessly  still at 4.44 on atv582 ????

Share this post


Link to post
Share on other sites
13 hours ago, marcodirect said:

when will we be getting the update for the atv582, I have another android box t95x and it runs android 6.0 flawlessly  still at 4.44 on atv582 ????

You can try this on 582 and see how it works.

 

Let me know

Thanks

Share this post


Link to post
Share on other sites

While the title also states the 1800E but it's not mentioned in that device section or notes, just want to confirm this same firmware will work?

Thanks! :)

Share this post


Link to post
Share on other sites

A

6 hours ago, Justin said:

You can try this on 582 and see how it works.

 

Let me know

Thanks

Also to add to this

The box you are referring to t95x, is using a much newer chipset S905X which comes with Android 6.0

The chipset in the ATV 582 is almost 3 years old, and they mainly only had support for it on Android 4.4

 

As I have said before, we rely on AMLogic the chipset manufacturer for Android OS updates.

Share this post


Link to post
Share on other sites
4 hours ago, PhoenixIce said:

While the title also states the 1800E but it's not mentioned in that device section or notes, just want to confirm this same firmware will work?

Thanks! :)

Ditto.  Will this work on the 1800e?  The original post is not clear on this, title of post includes 1800e, but no further mention of it.  Even the file name only refers to the 1900.

FBN

Share this post


Link to post
Share on other sites
1 hour ago, FlyByNight said:

Ditto.  Will this work on the 1800e?  The original post is not clear on this, title of post includes 1800e, but no further mention of it.  Even the file name only refers to the 1900.

FBN

I have been watching this thread for a long time and I'm also looking for clarity on wether this firmware update will work on the 1800e.   Please let us all know.  I don't want to assume it will.  

Share this post


Link to post
Share on other sites

I'm just wondering , do I have to do this using a SD card or can I just download directly in browser? I'm not the least bit techy but I follow instructions well lol

Share this post


Link to post
Share on other sites
12 hours ago, SS1455 said:

I'm just wondering , do I have to do this using a SD card or can I just download directly in browser? I'm not the least bit techy but I follow instructions well lol

If you want to use the boot card method/factory restore then an SD Card is required

Which is the first link of files.

 

If you want to just use the upgrade app with the IMG file, then an SD card or USB drive is ok

Share this post


Link to post
Share on other sites

WARNING - THIS WILL ERASE ALL DATA.

I downloaded the img file and started the update which started flawlessly. The Updater App found the file first attempt, no need to hit the menu button a zillion times, and it started the install smoothly. When it was installing "wifi analyzer" which was listed as 2/8 to be installed, it froze. I waited 30 minutes and then I was able to reboot the unit using the remote, I didn't need to unplug it. When it came back on a welcome screen thanked me for purchasing the product and walked me through a new setup. YIKES! Everything, I mean everything is gone. I did do a backup before doing the update so now I am going to hope everything worked with the back up. I'll let you know how I make out but wanted to first warn others of my experience so far. Not a good start MyGica, not a good start.......

Share this post


Link to post
Share on other sites

...and to top it off it appears the native App Backup and Restore is missing from this build. Now to figure out how to restore what I backed up.....grrr.......

Share this post


Link to post
Share on other sites

Well after another hour of my life lost thanks to this unit, I found the "App Backup and Restore" app online, downloaded it and got it installed and found my backup file...whew. So I have the primary apps back functional but still have some tweaking to do to get it back to pre-update status. From there I can start checking stability and overall performance of this latest release. Best luck to others out there when doing this update. Please be sure to share your experiences, good or bad, to the forum users and MyGica staff!

Share this post


Link to post
Share on other sites
12 hours ago, ksmitty said:

When it was installing "wifi analyzer" which was listed as 2/8 to be installed, it froze. I waited 30 minutes and then I was able to reboot the unit using the remote, I didn't need to unplug it.

I appear to be having the same issue.  Stuck at 2/8 and I'm trying to wait it out to see what happens.  I pressed the off button after 30 minutes but it came back (resumed) at the 2/8 mark installing the "Wifi Analyzer".

hrmmmmm

Share this post


Link to post
Share on other sites
46 minutes ago, darrylg said:

I appear to be having the same issue.  Stuck at 2/8 and I'm trying to wait it out to see what happens.  I pressed the off button after 30 minutes but it came back (resumed) at the 2/8 mark installing the "Wifi Analyzer".

hrmmmmm

Ok.  The trick to get past this bug is to make sure the ethernet cable is unplugged and it will install fine.  This bug should be fixed.

Share this post


Link to post
Share on other sites

Just to be clear on the subject of installing the firmware update I wanted to ask about the steps.  

 

1- download the file "update Mygica ATV1900AC 5.1 NONETFLIXHD 20161121.img file

2. Place the file on a USB device and insert it the box's USB 

Now this is where it gets foggy for me   

3.  Where is the app updater?  Is this in the setting menu  or is the app updater in the apps list (which for some reason I can't seem to find) 

Sorry for the crude steps but I'm on a phone and currently away from the box to upload screen shots of the "settings" menu I was referring too  which I think is the app updater.   Any info from anyone would be very much appreciated  

 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, frosty911 said:

Just to be clear on the subject of installing the firmware update I wanted to ask about the steps.  

 

1- download the file "update Mygica ATV1900AC 5.1 NONETFLIXHD 20161121.img file

2. Place the file on a USB device and insert it the box's USB 

Now this is where it gets foggy for me   

3.  Where is the app updater?  Is this in the setting menu  or is the app updater in the apps list (which for some reason I can't seem to find) 

Sorry for the crude steps but I'm on a phone and currently away from the box to upload screen shots of the "settings" menu I was referring too  which I think is the app updater.   Any info from anyone would be very much appreciated  

 

 

 

 

 

this is the app I am referring to.  is this the update app I use?

kodi1.JPG

kodi2.JPG

Share this post


Link to post
Share on other sites

Yes it is frosty, if you downloaded the img file to your sdcard then the app should see it. Also take note of the posts above from Darrylg apparently you should unplug the ethernet, if you have one plugged in. I did. Why this should matter and cause the system to reset the entire system, I don't know but hopefully the mods take note and make the necessary adjustment.

Share this post


Link to post
Share on other sites

 I'm wifi only so it shouldn't be a problem.  Thanks for be reply.  I'm a little nervous about the whole thing.  If I brick the box I'm gonna have a house full of angry little ones so that's why I asked.  Just wanted to be %100 sure.  I'll do it once I can find 30 minutes of quiet and alone time.  

 

Cheers 

Share this post


Link to post
Share on other sites

Is there any reason why this update makes the system unrooted?
I don't recall other releases having root taken away.

Share this post


Link to post
Share on other sites
52 minutes ago, darrylg said:

Is there any reason why this update makes the system unrooted?
I don't recall other releases having root taken away.

During the update process the bar got stuck about 1/2 way and the little android dude's ball stopped spinning.  So I unplugged it and tried again with success.  As for the rooting issue, I installed a third party app that requires the box to be rooted.  The app worked to my surprise from reading previous comments about it not being rooted.    Maybe it is still rooted and just requires a program to view the system?   

Share this post


Link to post
Share on other sites

I installed the firmware using the factory restore method with no issues. I was disappointed to see that it was not pre rooted every MyGica I have ever set up for a client of mine has been rooted from the factory. There are some apps that I run that require root access. Other then that the CPU is set to hot plug and there is no need as hotplug stops cpus cores to save battery life and seeing as this is on a power brick 24/7 it draws the same amount of power if its on or off or even if the unit is unpluged from the barrel connection its not a good choice. Performance setting gives access to all cpu cores and a better user experience with the draw back of battery life and thats a non point as its a plug in box. can you send out a patch for both Root and change the CPU Scaling Governor to Performance.

 

Thank you for your progress so far

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now