Jump to content
Sign in to follow this  
Stephen

I can't use mygica 1900 because the remote won't work

Recommended Posts

I can't use mygica 1900 because the remote won't work

I can't access kodi or anything else because the remote control isn't working. 

Can I fix this.. or do I need a new remote

 

A TV 1900AC

SN; MG190015111699

Share this post


Link to post
Share on other sites
On 2/25/2017 at 10:37 PM, Stephen said:

I can't use mygica 1900 because the remote won't work

I can't access kodi or anything else because the remote control isn't working. 

Can I fix this.. or do I need a new remote

 

A TV 1900AC

SN; MG190015111699

Have you tried re-pairing your remote?

Pair KR54

To pair:

1. place the RC close to the USB Dongle  (as close as possible)
2. hold down the FFWD and RWD Buttons
3. you will notice the blue LED starts flashing, wait till it stays on
4. release the buttons and pairing is done.

Share this post


Link to post
Share on other sites
3 hours ago, DANKYYZ said:

Sounds liek the same thing i'm going through.  would be glad to hear how this plays out. 

 

d

Did you try re-pairing the remote?

Share this post


Link to post
Share on other sites
40 minutes ago, DANKYYZ said:

yep. both remotes. 

 

 

How about new batteries?

Some users said after new batteries that it started working for them.

Share this post


Link to post
Share on other sites

Had the same problem with remote.  No different with new batteries.  Saw a post somewhere to install batteries in reverse order, meaning the wrong way, then install the correct way.  Remote worked again without any problems.  I didn't have to pair remote or anything, it just worked like from new out of the box.

Edited by hanke

Share this post


Link to post
Share on other sites

I too have remote problem. I have the KR-54 except I believe there may be 2 different style remotes? Instead of FF and RW mine has VOL+ and VOL-

Anyone know how to pair that specific remote ?

Share this post


Link to post
Share on other sites
On 7/15/2017 at 7:11 PM, TedG68 said:

I too have remote problem. I have the KR-54 except I believe there may be 2 different style remotes? Instead of FF and RW mine has VOL+ and VOL-

Anyone know how to pair that specific remote ?

The pairing instructions are at the bottom of the link below

http://wiki.mygica.tv/index.php?title=Kr54

 

Share this post


Link to post
Share on other sites

I think you all have an issue with the USB ports on the 1900ac instead of the Remote itself.

If you connect the Remote to a Computer, does it work for you but not on your 1900ac?

If so, then I suggest submitting your 1900ac for warranty by starting an RMA Ticket.

http://mygica.tv/help

Share this post


Link to post
Share on other sites
Sign in to follow this  

×