JZO

MyGica T230C causes blue screen of death on Windows 10

4 posts in this topic

Posted (edited)

MyGica T230C causes blue screen of death on Windows 10

Hi,

I have bought a new mygica USB Tv Tuner T230C device. I downloaded and installed the latest x64 driver for Windows 10 x64 and the TotalMedia 3.5 from http://mygica.com/html/Support/ 

When I try to scan channels, in the very begining of the process a blue screen of death occurs every time.

https://cloud.mail.ru/public/9ybp/fg9HRxWiH

As you can see the cydtv.sys file in the driver package is the root of the problem. This file is part of the device driver, see on the attached image.

The device is absolutely unusuable.

I bought it from aliexpress on 10 May, 2017 and it arrived here 25 May, 2017. The product link: 

https://www.aliexpress.com/item/DVB-T2-receiver-Geniatech-T230-DVB-T2-DVB-T-USB-TV-Stick/1857742736.html?spm=2114.13010608.0.0.nbJA5J

Everybody can help me please or have an idea what's going on?

Thank you!

driver.jpg

Edited by JZO

Share this post


Link to post
Share on other sites

купил T230C.

Windows 8.1 x64

не находит ни одного канала!! Что делать??

Share this post


Link to post
Share on other sites
On Fri May 26 2017 at 3:45 AM, JZO said:

MyGica T230C causes blue screen of death on Windows 10

Hi,

I have bought a new mygica USB Tv Tuner T230C device. I downloaded and installed the latest x64 driver for Windows 10 x64 and the TotalMedia 3.5 from http://mygica.com/html/Support/ 

When I try to scan channels, in the very begining of the process a blue screen of death occurs every time.

https://cloud.mail.ru/public/9ybp/fg9HRxWiH

As you can see the cydtv.sys file in the driver package is the root of the problem. This file is part of the device driver, see on the attached image.

The device is absolutely unusuable.

I bought it from aliexpress on 10 May, 2017 and it arrived here 25 May, 2017. The product link: 

https://www.aliexpress.com/item/DVB-T2-receiver-Geniatech-T230-DVB-T2-DVB-T-USB-TV-Stick/1857742736.html?spm=2114.13010608.0.0.nbJA5J

Everybody can help me please or have an idea what's going on?

Please try this driver:

https://mega.nz/#!a0Vm1KJS!ei6M0VxCvm9c2_NrSTYg7yv5eJ2IEtfrsDzdPlATBiQ

Share this post


Link to post
Share on other sites
12 minutes ago, zxl said:

This driver is the same as I downloaded from MyGica site. Version number: 1.32.1146.0

However I downloaded and installed it from the link above. No changes, blue screen of death occurs. I have tried to upgrade the Chipset driver of my motherboard, I have got the latest USB driver, Windows 10 is up-to-date. No luck. Any other idea? Newer driver?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now