Jump to content
LOIL99

DTS "skips" in Kodi 16.1 / No DTS Passthrough in Kodi 17.4

Recommended Posts

DTS "skips" in Kodi 16.1 / No DTS Passthrough in Kodi 17.4

I purchased this 1900 pro unit from Costco and am having issues with DTS. The unit comes with Kodi 16.1 installed and although I can get DTS to passthrough to my receiver in Kodi 16.1, the sound "skips" every 5 seconds or so. Very noticable. Dolby passthrough does not have the "skipping" issue. The video also stutters noticably even with framerate match turned on in Kodi.

So I updated to Kodi 17.4. That fixed the video stuttering issue but now DTS will not passthrough to my receiver and the "DTS capable receiver" setting that was available in Kodi 16.1 is not longer available to be selected in Kodi 17.4.  Any DTS signal is just sent as 2.0 PCM to my receiver from the Gica. Not ideal and a deal breaker for me if there is no fix.

What I am hoping to find help with is how to enable this device in Kodi 17.4 to passthrough  DTS to my receiver. I am not looking for a workaround like having the Gica convert DTS to AC3. I want my receiver to do all sound decoding.

Thank you in advance for any help!

Share this post


Link to post
Share on other sites

I should add that the sound is via HDMI for the Gica to the Onkyo receiver and I have to lollipop setting as "HDMI" under sounds menu.

  • Sad 1

Share this post


Link to post
Share on other sites

Hi LOIL99, have you got any offline response, I have similar silence with the ATV586 ATSC not picking up the audio thru the HDMI into an older DTS enabled Yamaha Receiver.

 

Share this post


Link to post
Share on other sites
On 9/20/2017 at 4:11 PM, RichK said:

Hi LOIL99, have you got any offline response, I have similar silence with the ATV586 ATSC not picking up the audio thru the HDMI into an older DTS enabled Yamaha Receiver.

 

The ATV 586 does not support DTS via Hardware decoding through the HDMI, that is why it won't work for you.

Share this post


Link to post
Share on other sites
On 9/17/2017 at 9:28 PM, LOIL99 said:

DTS "skips" in Kodi 16.1 / No DTS Passthrough in Kodi 17.4

I purchased this 1900 pro unit from Costco and am having issues with DTS. The unit comes with Kodi 16.1 installed and although I can get DTS to passthrough to my receiver in Kodi 16.1, the sound "skips" every 5 seconds or so. Very noticable. Dolby passthrough does not have the "skipping" issue. The video also stutters noticably even with framerate match turned on in Kodi.

So I updated to Kodi 17.4. That fixed the video stuttering issue but now DTS will not passthrough to my receiver and the "DTS capable receiver" setting that was available in Kodi 16.1 is not longer available to be selected in Kodi 17.4.  Any DTS signal is just sent as 2.0 PCM to my receiver from the Gica. Not ideal and a deal breaker for me if there is no fix.

What I am hoping to find help with is how to enable this device in Kodi 17.4 to passthrough  DTS to my receiver. I am not looking for a workaround like having the Gica convert DTS to AC3. I want my receiver to do all sound decoding.

Thank you in advance for any help!

We are fixing this passthrough issue on the 495P/1900P

Share this post


Link to post
Share on other sites

I have a 1900 pro connected to an older Yamaha receiver, and found my DTS skipping for a fraction of a second every 20 -30 seconds.  I also notice that the 5.1 sound display indication on the receiver blips off when this occurs (so looks like digital signal is interrupted for a second. I should also mention I am using the optical connection to my receiver as it predates HDMI.

Justin said above that ATV 586 does not support DTS via Hardware decoding, and so also applies to 1900P.  As DTS uses software decoding, looks to me like the processors is getting overloaded every once and a while.  I also read in another thread somewhere that the Lollipop OS in the 1900 Pro had been set up to limit speed of the processing cores (possibly to keep from overheating).  The thread went on to explain there is a way to change this but meant rooting the box and running an application to adjust this OS parameter (but looked a little too risky to me so I did not do).

I also tried updating from KODI 16.1 to 17 but did not like the new look, and had trouble playing some movies (got some studder) so reverted back (and have stuck with 16.1 - which I believe is the version still used in the official 1900P software download).

On thing I did notice was when I switch from on older 4 port Dlink Gigabyte switch to a newer 8 port Dlink Gigabyte switch, the frequency of skips went down to be much more tolerable (which again make me think it is a processor overload issue).

As was said, the "DTS capable receiver" setting that was available in Kodi 16.1 is not longer available to be selected in Kodi 17.4 , and I believe this may have been done on purpose, because they could not get it to work smoothly.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×