Jump to content
Scotie

A TV 495 Pro freezing.

Recommended Posts

A TV 495 Pro freezing.

Hi, my MyGica A TV 495 Pro is now freezing on the home screen after being put on.Can anyone please give me some advise on how to resolve this 

Share this post


Link to post
Share on other sites

Thanks for posting this but a hard reset sounds like a last resort.I did find out how to un-freeze it from a comment that someone posted on YT.Press and hold the volume up and page up buttons on the remote for 5 seconds,the blue light will flash then press one of the directional buttons.The poster said the remote needed to be paired,whatever that means.But I could care less because it fixed my problem.

Share this post


Link to post
Share on other sites

Worked like a charm. Thanks a ton. Where do you read these posters? I'd like to browse through them next time there's a problem.

Thanks once again.

Share this post


Link to post
Share on other sites

Thank you for the information above but I can’t even get to the settings screen. Mine is frozen at the MyGica Seeing is Believing screen and my remote won’t work. I’ve changed the batteries in the remote and still the centre button keeps flashing as if it’s not connected. Please help as I don’t see how else to do a hard restart.

Share this post


Link to post
Share on other sites
On 12/2/2018 at 1:18 PM, Alisha said:

Thank you for the information above but I can’t even get to the settings screen. Mine is frozen at the MyGica Seeing is Believing screen and my remote won’t work. I’ve changed the batteries in the remote and still the centre button keeps flashing as if it’s not connected. Please help as I don’t see how else to do a hard restart.

I’m sorry to hear this is happening. The remote is flashing because the unit is not loading the operating system. 

It seems that the unit has run into either a software or hardware issue, with it likely being the latter. 

If you’re kinda techy, you can try reloading the firmware if you have an SD card. 

Please make sure you have the 495 pro, and not the 495 pro hdr. If it’s the hdr, it will be different files than what I list below. 

Follow the instructions carefully and consider watching the video. 

Mid you’re not comfortable doing this, you can reach out to our warranty center at mygica.tv/help if you’re in North America. 

Mid the unit is under warranty, there won’t be any cost other than shipping the unit to us. If it’s out of warranty, you’ll likely have to pay a small service fee as well as shipping to us. Shipping it back to you will be included in the service fee. 

 

Please se let me know if this helps. 

Share this post


Link to post
Share on other sites

Hi there. I tried to do a firmware update, but had a power failure during the process. Now I cannot hard reset or reload firmware. I have the 495 Pro. I downloaded the factory firmware from  your website, format to FAT32 (1GIG SD Card) and copied the image on the root. Pulled Power and held down the Power Button while plugging back in, with the SD Card inserted...but nothing. The display stays dead and I left it on for more that 15min. (Not sure how long the firmware installation takes). I'm now at a dead end. Please can someone assist? Thank you. P.S. Definitely not a hardware issue. Have been working fine until I tried the stupid update. Thank you.

Share this post


Link to post
Share on other sites
On 12/9/2018 at 6:07 AM, GrantDW said:

Hi there. I tried to do a firmware update, but had a power failure during the process. Now I cannot hard reset or reload firmware. I have the 495 Pro. I downloaded the factory firmware from  your website, format to FAT32 (1GIG SD Card) and copied the image on the root. Pulled Power and held down the Power Button while plugging back in, with the SD Card inserted...but nothing. The display stays dead and I left it on for more that 15min. (Not sure how long the firmware installation takes). I'm now at a dead end. Please can someone assist? Thank you. P.S. Definitely not a hardware issue. Have been working fine until I tried the stupid update. Thank you.

Hi there sorry for the delay. 

It seems the unit was bricked during the uodate process if there was a power failure. 

Please head over to mygica.tv/help and start a warranty ticket if you are in North America. If the unit is still under warranty, just ship it to us once approved and we will take care of you. 

If it is no longer under warranty, there may be some small charges to get it going again or replace the unit. 

Share this post


Link to post
Share on other sites

Thank you for your response. 'Only problem is, I'm in South Africa and the device is 22 days out of warranty. Is there a way I can try to un-brick it myself?

Thanks again for all your help.

Share this post


Link to post
Share on other sites

I’m sorry, but there really isn’t a way to have that done without it being in our tech warehouse. 

Maybe reach out to your local distributor to see if they can do an out of warranty repair. South Africa sells a lot of mygica, so I would assume they have a repair center as well. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×