Jump to content
Sign in to follow this  
Ricardo Jardim

The box freezes after the Lollipop screen

Recommended Posts

The box freezes after the Lollipop screen

I've purchased this box in Canada in june  2017, but only now I had the chance to start using it. I live in Brazil and my English is not as natural for me as it may be for you guys that, hopefully will try to help me - I apologise beforehand if I, by any chance, write  something that sounds weird... 

Unfortunately, after I did all the inicial setup, it started freezing after the Lollipop screen and that prevents  me from getting back to the home screen. It happens 90% of the time and sometimes it only works again after I turn  it off and restart after a long time.

Any sugestion? Is this a firmware problem?  Anything I can do in the few occasions when the box answers to the RC? I'd really appreciate and thank you in advance for any 

Share this post


Link to post
Share on other sites
On 2/11/2018 at 8:54 AM, Ricardo Jardim said:

The box freezes after the Lollipop screen

I've purchased this box in Canada in june  2017, but only now I had the chance to start using it. I live in Brazil and my English is not as natural for me as it may be for you guys that, hopefully will try to help me - I apologise beforehand if I, by any chance, write  something that sounds weird... 

Unfortunately, after I did all the inicial setup, it started freezing after the Lollipop screen and that prevents  me from getting back to the home screen. It happens 90% of the time and sometimes it only works again after I turn  it off and restart after a long time.

Any sugestion? Is this a firmware problem?  Anything I can do in the few occasions when the box answers to the RC? I'd really appreciate and thank you in advance for any 

Have you tried re installing the firmware?

 

Share this post


Link to post
Share on other sites

I did install the  March firmware but it just doesn't work.   There is nothing else that I can do myself.  I was thinking about mailing it to the manufacturer for their review/repair.  Could you please send me the e-mail address  of the services division, so I could discuss the issue with them?

Thank you!

Ricardo

Share this post


Link to post
Share on other sites
On 6/16/2018 at 8:33 PM, Ricardo Jardim said:

I did install the  March firmware but it just doesn't work.   There is nothing else that I can do myself.  I was thinking about mailing it to the manufacturer for their review/repair.  Could you please send me the e-mail address  of the services division, so I could discuss the issue with them?

Thank you!

Ricardo

With respect to warranty period, create an RMA Request via http://help.mygica.tv and our repair centre can fix it.  

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...