Jump to content

Recommended Posts

Monitor display always on and off

Hello everyone, just joined and wanted to know the solution to the frequent on and off of my display

using MyGica 195A USB to HDMI. Also how to maximize resolution, 

Share this post


Link to post
Share on other sites
8 hours ago, dantep said:

Monitor display always on and off

Hello everyone, just joined and wanted to know the solution to the frequent on and off of my display

using MyGica 195A USB to HDMI. Also how to maximize resolution, 

How do you connect all the devices?

For your first question, please make sure the devices are well connected via the cables.

For your second question, you can maximize resolution on your PC.

Share this post


Link to post
Share on other sites
1 hour ago, zxl said:

How do you connect all the devices?

For your first question, please make sure the devices are well connected via the cables.

For your second question, you can maximize resolution on your PC.

I have a 2 monitor setup connected to my laptop. One of my monitors is connected directly via vga cable, this works fine. The second monitor I connected via the mygica 195a Hdmi to usb, this is the problem, always flickering and not stable at all.

Share this post


Link to post
Share on other sites
8 hours ago, dantep said:

I have a 2 monitor setup connected to my laptop. One of my monitors is connected directly via vga cable, this works fine. The second monitor I connected via the mygica 195a Hdmi to usb, this is the problem, always flickering and not stable at all.

Follow these steps, 

From Main screen Select Settings // Display // Screen resolutions // Turn off Auto Detection.  

please update me after you do that.

Share this post


Link to post
Share on other sites
4 hours ago, bindaredondat said:

Follow these steps, 

From Main screen Select Settings // Display // Screen resolutions // Turn off Auto Detection.  

please update me after you do that.

Ok tried it, still flickers.

Replaced the HDMI cable, now Ok . Tried again your suggestion, message to turn off gone.

Thanks to all who posted.

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, dantep said:

Ok tried it, still flickers.

Replaced the HDMI cable, now Ok . Tried again your suggestion, message to turn off gone.

Thanks to all who posted.

Happy to know your problem is solved. Any further questions, please let us know.

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, dantep said:

Ok tried it, still flickers.

Replaced the HDMI cable, now Ok . Tried again your suggestion, message to turn off gone.

Thanks to all who posted.

That is a good news, I was waiting for you to answer then I was going to give you 2nd option to replace your HDMI cable.  

I am happy it all worked out.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×