Jump to content
StephVan

MyGica ATV1960

Recommended Posts

MyGica ATV1960

Purchased a mygica atv1960 a month ago from takealot.

Let me get to the point.  Nice device and all, however there are a few issues 

Firstly sometimes when we switch the tv(samsung)  off (not the tvbox) and switch it on the next day, the screen is black with a HDMI message indicating its not receiving a signal from the box.

To fix this, i need to manually pull the cable from the box and plug it back in for it to reboot and start again.  Its a hassle, at that pricetag it should work right?

Next issue,  at times, (sometimes twice a day) the box just hangs/stalls, which also requires pulling the cable and replug to reboot.

So my questions to Mygica support, 

1. Can it be fixed, and how do we do this?.

2. If the issues can't be fixed,would you please refund or exchange.(for something that works)

 

I paid quite a lot for this tv box and I expect it to work without any issues.

Kindly please advise me on how to go about this.

Your Client

Edited by StephVan
w

Share this post


Link to post
Share on other sites

Hi,

sorry for the late reply. We have had some forum issues and I am personally playing a bit of catchup. 

Regarding the issue with your tv not detecting an input, it may be relating to the “CEC” controls in settings. This is a feature to allow turning on the tv with the mygica power button when turning on the device. 

Please locate this setting and try turning it off. 

As for freezing, is this in one particular app, or is this happening no matter where you are? Is the box hot to the touch if it’s in any app? (The box is usually quite warm normally but not hot) 

Share this post


Link to post
Share on other sites

Here it is just 5 days into owning an ATV1960 and I am sad to say it crashes 2 or 3 times per day!  I have done a factory reset and even though it is only using the installed YOUTUBE feature it freezes after viewing as few as 10 videos…
Sad to say that I am not impressed but any suggestions would be greatly appreciated!

Just my 2¢

Share this post


Link to post
Share on other sites
1 hour ago, RYCBAR said:

Here it is just 5 days into owning an ATV1960 and I am sad to say it crashes 2 or 3 times per day!  I have done a factory reset and even though it is only using the installed YOUTUBE feature it freezes after viewing as few as 10 videos…
Sad to say that I am not impressed but any suggestions would be greatly appreciated!

Just my 2¢

Hi Rycebar,

this is a different issue than what is being described above. 

Wgen you say freezing, does the entire unit stop working? If you press the home button does anything happen? 

Is the unit hot? 

 

This seems like a hardware issue. I have been using my 1960 for awhile now without any YouTube issues. 

We can get this exchanged for you here over at mygica.tv/help or consider exchanging at the store. That definitely isn’t normal. 

Share this post


Link to post
Share on other sites

To make a long story short, I purchased an open box MyGica 1960 and have had nothing but freezing issues.  I have done a factory reset and rebuilt the apps that I use but no matter what I do or use while using the factory installed versions of 4K Movie player, YouTube, Kodi, it simply freezes up (not always right away) and needs to be unplugged to make it work!  To make things even harder to figure out, if the box sits inactive for a period of time it also freezes.  I would do a hard reset but MyGica does not have the image file online yet (at least that I can see) and I would try this as the factory install may have its own internal glitches.  

Share this post


Link to post
Share on other sites

The “hard reset” is the same as a factory reset. It reinstalls the operating system. 

 

It really seems like there is a hardware issue and maybe the previous owner knew this? 

Where did you manage to buy an open box 1960? 

Share this post


Link to post
Share on other sites
1 hour ago, RYCBAR said:

BB return!

That’s even more strange then. They aren’t supposed to sell returns or open box units. They are supposed to come back to us. 

Are you able to return the device? 

Share this post


Link to post
Share on other sites
  1.  
On 10/26/2018 at 12:06 PM, MyGica Support said:

That’s even more strange then. They aren’t supposed to sell returns or open box units. They are supposed to come back to us. 

Are you able to return the device? 

The box did come from MG North America in Brampton...

I will try moving the remote dongel but here is exactly what is happening.

 

This box (an ATV1960) loads or boots the MyGica startup screen and compared to the video display from my 1800e, it is quiet jittery and cheap looking (it is no longer smooth).  It then defaults to the N or Nougat screen and all of a sudden it appears to be loading the old Google Nexus Android Launcher (the orange screen with multiple configurations of odd shaped triangles) but flips back into the MyGica 4K HD Android Launcher.  The box has had freezing issues since day one and by freezing I mean that it will freeze anywhere and anytime no matter what it is doing!  It freezes while sitting on the home page, it freezes while steaming video using YouTube, it freezes while playing content from a self-contained source, and it freezes while simply doing cleanup on both the internal and external hard-drives.  In other words, it freezes up no matter what it is up to and without any logic of heavy use or not!

PS.  The term freezes means that the box is no longer HOT or still active.

 

Share this post


Link to post
Share on other sites

This unit clearly has a hardware issue. 

I am familiar with the term “freeze” but a lot of people mistake an app freezing for the box freezing, I was simply looking for further clarification to try to provide the best help I can. 

 

This unit should not have been sold as a open box as clearly it seems it was returned for the exact reasons you outlined. 

 

 

Share this post


Link to post
Share on other sites
On 10/31/2018 at 12:58 AM, RYCBAR said:

No problem and thanks for the support.  I received an update file to try and will let everyone know what happens.
S....

Did this work for you?

Just wondering because I am in the process of returning my atv1960 which also freezes very often.

 

 

Share this post


Link to post
Share on other sites
On 9/28/2018 at 11:19 AM, MyGica Support said:

Hi,

sorry for the late reply. We have had some forum issues and I am personally playing a bit of catchup. 

Regarding the issue with your tv not detecting an input, it may be relating to the “CEC” controls in settings. This is a feature to allow turning on the tv with the mygica power button when turning on the device. 

Please locate this setting and try turning it off. 

As for freezing, is this in one particular app, or is this happening no matter where you are? Is the box hot to the touch if it’s in any app? (The box is usually quite warm normally but not hot) 

Hi

this has happened in many different apps,  youtube, netflix and VLC player, I would say the device is warm not really hot.  What is the standard warranty on a device like this?

I am in the process of returning this product to the seller(takealot.com) who will probably send it to the supplier syntech in south africa.

Share this post


Link to post
Share on other sites
7 hours ago, StephVan said:

Hi

this has happened in many different apps,  youtube, netflix and VLC player, I would say the device is warm not really hot.  What is the standard warranty on a device like this?

I am in the process of returning this product to the seller(takealot.com) who will probably send it to the supplier syntech in south africa.

The standard warranty should be 1 year from the date of purchase.
But best to check with your seller for a more clear answer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...