kthurai2i

How to restore ATV 582

54 posts in this topic

Hello, I was trying to upgrade firmware on ATV 582 (from online,not from sdcard), but prompted me format internal sd card since it didn't enough storage space.

Accidentally I have clicked on yes. Now the unit is not booting up

Can you please help me out to restore the box please....

I don't see anything displaying on my tv.

Share this post


Link to post
Share on other sites
Hello, I was trying to upgrade firmware on ATV 582 (from online,not from sdcard), but prompted me format internal sd card since it didn't enough storage space.

Accidentally I have clicked on yes. Now the unit is not booting up

Can you please help me out to restore the box please....

I don't see anything displaying on my tv.

You do not get a picture at all?

Usually when this happens you at least get taken to the Android Recovery screen

Share this post


Link to post
Share on other sites

Correct, I am not seeing anything on TV display. The TV sees the display signal, but black screen. Usually, if there is no signal, the tv outputs "no signal message".

I had latest firmware on external micro sd card, When I was trying to install the firmware from micro sd card, it didn't see the firmware files. Then i decided to use online firmware upgrade, that when it complain about there is not enough storage and prompted me to format the sd card. I clicked on yes. This is what formatted internal storage.

Please help me the the unit back online..

Share this post


Link to post
Share on other sites

someone has helped me restore the ATA582. Everything is ok now. I just need to upgrade firmware from 20140604 to latest one...

Share this post


Link to post
Share on other sites

How did you restore your ATV 582, I have the same problem. Try to do the update and now it does not start up.

Blue light is on but blank screen.

Share this post


Link to post
Share on other sites
How did you restore your ATV 582, I have the same problem. Try to do the update and now it does not start up.

Blue light is on but blank screen.

Does it take you to the Android Recovery screen at all?

Share this post


Link to post
Share on other sites

Hi i have the same problems, blank screen etc, have tried the link you posted in order to repair but found that is only to update and not repair. Am at my wits end with no solution in site so hope you will share the sequence of repair or the site with me

Share this post


Link to post
Share on other sites
Hi i have the same problems, blank screen etc, have tried the link you posted in order to repair but found that is only to update and not repair. Am at my wits end with no solution in site so hope you will share the sequence of repair or the site with me

If you can get into recovery mode using the reset button on the bottom of the unit, you can use those files to install again, and it should fix your unit.

If not, you can also try this update.

viewtopic.php?f=119&t=2163

I know it says it is for the 1800E, but I have personally used this to bring some 582 warranty units back to life.

Share this post


Link to post
Share on other sites

Justin, with regard to your last comment in this post..."If you can get into recovery mode using the reset button on the bottom of the unit, you can use those files to install again, and it should fix your unit."...

I have 2 questions:

1. What if you CANNOT get into recovery mode using the rest button? (Unit does not respond at all. Centre LED remains steady blue no matter what user intervention is attempted).

2. How could the good people at Mygica release a firmware upgrade that is capable of destroying a device? Granted the warning signs are there if the user is diligent in reading the update warning prompts VERY CAREFULLY but honestly, most people who purchase these units are laymen who's interest and tech-savvy don't extend beyond much wanting to enjoy a bit of online streaming entertainment.

Awaiting your response

Martin

Share this post


Link to post
Share on other sites
Justin, with regard to your last comment in this post..."If you can get into recovery mode using the reset button on the bottom of the unit, you can use those files to install again, and it should fix your unit."...

I have 2 questions:

1. What if you CANNOT get into recovery mode using the rest button? (Unit does not respond at all. Centre LED remains steady blue no matter what user intervention is attempted).

2. How could the good people at Mygica release a firmware upgrade that is capable of destroying a device? Granted the warning signs are there if the user is diligent in reading the update warning prompts VERY CAREFULLY but honestly, most people who purchase these units are laymen who's interest and tech-savvy don't extend beyond much wanting to enjoy a bit of online streaming entertainment.

Awaiting your response

Martin

We dont design or release firmware that will destroy your box as long as the instructions are followed to load it, then you should have no issues.

As long as you are loading firmware to your box using a Formatted FAT 32 SD Card. and the Upgrade app on the box, then the update should go through without issues. Or you can load firmware from recovery screen.

When and where did you purchase the unit from? I can try and help with the easiest way to get the unit replaced under warranty.

Let me know

Thanks

Share this post


Link to post
Share on other sites

The firmware was updated via OTA prompt on the screen. Upon installation a message was displayed regarding a lack of space on the SD card and formatting being required (this is the point I am trying to raise). Once the user agrees to formatting of the "SD card" it would appear that the internal storage is wiped rendering the unit effectively useless...unless it can be revived? Can it? How?

I have already attempted, and failed, to get a response from the unit by pressing the reset button and then plugging in power while maintaining pressure on the reset switch for a further 5sec. The unit appears to be bricked. It was purchased from an online vendor and is indeed an authentic Mygica ATV 582. I have in the past updated the firmware OTA successefully but the issue at hand seems to be as a direct result of the DEC update, as confirmed by you in a previous post where you cautioned users to download the firmware update and unzip the contents thereof onto an SD card rather than to attempt OTA update as it would wipe the unit. I could find that post if you do not recall.

Please don't take it as though I'm trying to pick a fight, I'm honestly not. At this point I would just like to know if I can consider this thing a paperweight or if you feel there is yet hope of revival.

Share this post


Link to post
Share on other sites

Ps. As far as replacement under warranty...doubtful as I live in South Africa and I can't imagine you would honour a warranty abroad?

Share this post


Link to post
Share on other sites

This is just an android distro with a skin on top so why exactly would formatting the internal SD nuke the OS? There should be separate mount points for system files and then one for an internal SD (mnt/sdcard)....like every smartphone manufacturer on the planet does.

How many people that purchase these bother to browse these forums? I'd hazard to guess very few, so if your going to provide OTA updates for the layman then don't provide them a way to brick the system.

I'd hope this would be addressed in future builds, it may save some headache...just my 0.02c personally I like the unit for the most part after I've figured out it's quirks it really impresses me.

Share this post


Link to post
Share on other sites

@mart_dev try the procedure here to unbrick, you need a stock rom and a good recovery.

viewtopic.php?f=39&t=2536

Make sure that have read the whole procedure as it differs slightly from the normal unbricking procedure.

If this doesn't help, I'll post a hardware and software procedure how to unbrick later.

Nice, another South-African onboard, welcome. Where did you buy it and RMA should still be okay as normal vendors usually have 1 year warrantee on their goods.

Share this post


Link to post
Share on other sites
This is just an android distro with a skin on top so why exactly would formatting the internal SD nuke the OS? There should be separate mount points for system files and then one for an internal SD (mnt/sdcard)....like every smartphone manufacturer on the planet does.

How many people that purchase these bother to browse these forums? I'd hazard to guess very few, so if your going to provide OTA updates for the layman then don't provide them a way to brick the system.

I'd hope this would be addressed in future builds, it may save some headache...just my 0.02c personally I like the unit for the most part after I've figured out it's quirks it really impresses me.

We have stopped OTA updates for now since October. Till we get to a build that wont require so many changes when we do OTA Updates in the future, and also wont factory reset anything either.

Till then, we are just providing Manual updates, and any new shipments we get come with the latest update available pre installed.

The OTA Updates do not brick boxes, they just might throw it into recovery, which just requires a manual update. We have stopped OTA for now, till we build a much easier and better solution for OTA updates.....

Share this post


Link to post
Share on other sites

Hi Guys,

I have similar issues where I tried the OTA update, and clicked OK to format the sd card... I can still access the recovery screen but its not picking up any files form the SD card.

Please help....

Also from South Africa.. :shock:

Share this post


Link to post
Share on other sites

Try using a USB drive in recovery with the IMG file on it.

See if it finds it

Share this post


Link to post
Share on other sites
Try using a USB drive in recovery with the IMG file on it.

See if it finds it

Thanks Justin it worked!! :D

Share this post


Link to post
Share on other sites

I too seem to be having this trouble. Solid blue centre LED with no other response. No signal from ATV582. Using MicroSD formatted with SD Formatter 4 or using clean USB key. Both medias were 4GB in size with nothing else on them except for the following:

dd.exe

factory_update_param.aml

factory_update_param.ubt

readme.txt

recovery.img

sd_bak

u-boot.bin

uboot_MX.cmd

update_Mygica_ATV582_20150721.img

then followed these instructions:

1 Run uboot_MX.cmd file on PC, it will pop up a window to remind you to continue, just press any button£¬until it automatically exit.

2 Insert the boot card into the box; press and hold the upgrade button, plug in power adapter;

3 Hold the button for about 10 seconds;

4 Release the button as soon as the LED start flashing and wait for 1-2 minutes(screen has no display at this time),please don¡¯t plug out the power;

and then normally you will see robot screen it is updating the firmware;

5 After be finished, the box will restart.

My problem is the LEDs never start flashing. I am sure I am pressing the reset button correctly as I can feel the slight click as I press and release with a paperclip.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now