Jump to content
Dave Klyne

Remote unable to turn Mygica atv1960 on

Recommended Posts

Remote unable to turn Mygica atv1960 on

I have paired my KR301 204 G Air mouse remote with Mygica ATV 1960, but I am unable to start the Mygica with the remote.  The only way I can start it is by unplugging it and plugging it back in then it starts.  I have tried putting it on "Standby" and turning it off but it will only start again by unplugging it.  It will reboot with the remote and turn off.  But it will not start with the remote.  Any suggestions?  also where can I download and install new firmware?   This was purchased from Bestbuy in Canada, and is my second unit as I exchanged my first one for the same reason.  I have changed the USB dongle several times to each different slot, but it makes no difference.

Share this post


Link to post
Share on other sites
11 minutes ago, Dave Klyne said:

Remote unable to turn Mygica atv1960 on

I have paired my KR301 204 G Air mouse remote with Mygica ATV 1960, but I am unable to start the Mygica with the remote.  The only way I can start it is by unplugging it and plugging it back in then it starts.  I have tried putting it on "Standby" and turning it off but it will only start again by unplugging it.  It will reboot with the remote and turn off.  But it will not start with the remote.  Any suggestions?  also where can I download and install new firmware?   This was purchased from Bestbuy in Canada, and is my second unit as I exchanged my first one for the same reason.  I have changed the USB dongle several times to each different slot, but it makes no difference.

Hi there,

we are aware of this bug. Once updated and fixed, you will get prompted after a reboot to accept the automatic update. 

Mom not sure when this will happen, so for now it’s up to you if you want to power it down and unplug to turn on, but I just leave mine on all the time. These things don’t have any moving parts like fans or anything, so leaving them on is similar to leaving your cell phone turned on. 

Share this post


Link to post
Share on other sites

Same old story. I think guys a GTA better give up as it is the same old  problems with every unit you sell.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×