Jump to content

Remote Control Issues

Recommended Posts

Remote Control Issues

I have a ATV 495 Pro with the air mouse and have been experiencing issues lately:


1. Power button does not work at all. I have to manually press the power button on the unit to turn it on

2. After the unit gets to the main page, remote is often unpaired and unresponsive. Tried parking using Vol+ and Page+ and it does not work. Changing and removing batteries on the remote does not work. The only thing that works is removing the dongle and reinserting it again then pairing it again. A huge headache if this needs to be done every time.

Please assist. Thanks!

Share this post

Link to post
Share on other sites

Hi and sorry you’re having this issue. 

This could be a few different issues that may be relating to;

-The software on the device itself

-a problem with with the remote

-a USB port failure  


have you tried using the other usb slot? Does it make any difference? 

Have you factory reset the system to see if the stability improves? Usually if the remote won’t turn on the box, it would be relating to the line of site being blocked (the power button is the only button that needs to have the remote pointing at the face of the unit to work) or something has been installed onto the system that has changed the behavior of the launcher. This could be many things that could potentially do stuff like this.

be sure to back up anything you may have on the box before doing that as it will revert it back to how it was when you bought it by reinstalling the operating system fresh.


Please check out the above info and let me know the results.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now