Jump to content


This topic is now archived and is closed to further replies.


Using generic remote controls with the ATV582

Recommended Posts

Greetings from the UK.

I am disappointed that I have been unable to purchase a spare remote control for the ATV582 in the UK.

I have tried several 'generic' android remote controls and find none are able to 'power on' the ATV582 from 'standby' condition.

I have to use the MyGica r/c to get the box out of 'standby', but once powered on, the functionality of the generic r/c is 100% with no problems.

The generic r/c will now switch the ATV582 between 'standby' and 'power on' modes repeatedly, but if left in 'standby' mode for longer than 30 seconds, then the ATV582 once again requires the MyGica r/c to get it out of 'standby'. All the generic r/cs I've tried exhibit peculiar behaviour with the ATV582.

I have noted that when using the MyGica r/c, then the box simply goes into 'standby', but the generic r/c provides the choice or 'standby' or 'reboot'.

The Android keycodes are presumably different between the Mygica and generic remote controls, but there is also some sort of key timeout on the box as afterany length of time, it requires one key press to get the attention of the box followed by a second press to activate the function.

All the generic r/cs behave the same and work correctly with other manufacturers boxes, so it is my belief that the keycodes for the MyGica are non-standard.


My questions are:-

1). Why does the ATV 582 need the original remote control to initially get it out of standby?

2). Why does the generic remote control work fine after 1). above, and then repeatedly puts the box into standby and power on with no problem?

3). Why does the the ATV 582 revert back to condition 1). above after 30+ seconds in standby.

Perhaps I should also ask why there is no supplier for MyGica remote controls in the UK.


Thank you for any advice.

Dennis in UK.

Share this post

Link to post
Share on other sites

Hi Dennis,


I am sorry to hear that you are having trouble with getting a remote in the UK. I am not familiar with the UK division of the brand. I assume you have tried amazon and site alike?

The reason why it must be a MyGica remote, is because android does not have the function built in native. We had to put in an IR interface to do this, thus needing the specific MyGica IR code to turn it on.

Share this post

Link to post
Share on other sites

  • Create New...