Jump to content
Plaatkoek

Mygica 329x - has power but don't want start up

Recommended Posts

Mygica 329x - has power but don't want start up

Hi, looked everywhere on this forum for help, but can't find something that works. 

My MyGica 329x has all of a sudden just show the red status light, Net is green, but doesn't want to start up if I press the power button. TV shows "check signal"

I can't upgrade firmware, because I can't start it. I've tried to use another power cable and HDMI and TV, but still the problem exists. 

I have another Mygica 329x and tried to swop them, but the one that gives the issue, still does not want to start. 

Any advice? 

Share this post


Link to post
Share on other sites

Mine does the same, the remote will some times work to power it on. How ever what works best is to press the ovel shaped power button on the front of the box 2 quick presses and it turns on. 

 

Seams there is a issue with powering back up after its gone in to stand by. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...