Jump to content

MyGica HD Cap X, doesn't record SOLVED

Recommended Posts

MyGica HD Cap X, doesn't record SOLVED

HI guys , if you  have a problem with recording on your Flash Drive or HDD on mygica HD cap X

You  need to  convert  your Flash Drive Or HDD to the  MBR DISK with any partition manager software

I just used   AOMEI Partition Assistant 

After that just go in the Disk Management on Windows,  DELETE the partition and create new one (for windows 10 users)  


REMEMBER Disk format Must be FAT32

NOW u can record easily And copy your files on computer .💥 

I hope , it solved your problems

Sorry for bad Grammar🤕

Edited by razor90

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...