Jump to content
Sign in to follow this  
Rolland

ATV485X android 6.0 TV Box

Recommended Posts

ATV485X android 6.0 TV Box

Hi Guys,

desperately need assistance / advice...i have a MyGica ATV485X, i lost my remote and cannot seem to turn my box on.

had it packed away for a while until we moved house but cannot seem to locate the remote now, i use the usb pot from my tv for power to the box, the red light is on with the power indicator constant red but nothing else happens, i tried pushing the button to switch it on but nothing happens, i even tried holding the power button down for a few seconds but also nothing.

so basically it seems like i have to use a remote control to switch this box on....please confirm, please help....!!!

Share this post


Link to post
Share on other sites

 

 

On 1/2/2021 at 9:46 PM, Rolland said:

ATV485X android 6.0 TV Box

Hi Guys,

desperately need assistance / advice...i have a MyGica ATV485X, i lost my remote and cannot seem to turn my box on.

had it packed away for a while until we moved house but cannot seem to locate the remote now, i use the usb pot from my tv for power to the box, the red light is on with the power indicator constant red but nothing else happens, i tried pushing the button to switch it on but nothing happens, i even tried holding the power button down for a few seconds but also nothing.

so basically it seems like i have to use a remote control to switch this box on....please confirm, please help....!!!

 

Share this post


Link to post
Share on other sites
On 1/2/2021 at 2:46 PM, Rolland said:

ATV485X android 6.0 TV Box

Hi Guys,

desperately need assistance / advice...i have a MyGica ATV485X, i lost my remote and cannot seem to turn my box on.

had it packed away for a while until we moved house but cannot seem to locate the remote now, i use the usb pot from my tv for power to the box, the red light is on with the power indicator constant red but nothing else happens, i tried pushing the button to switch it on but nothing happens, i even tried holding the power button down for a few seconds but also nothing.

so basically it seems like i have to use a remote control to switch this box on....please confirm, please help....!!!

Are you sure it's not the ATV 495X ? Cause i don't think the 485X exists !

Maybe the reason you packed it away was because you bricked it back then, because the box does not brick by itself in storage.

If you pressed on the Power On/Off button and it stays red this means the box was brick during a firmware update.

You can try updating the firmware again via the SD card,  but I doubt that would revive it as MyGica is infamous for not supplying an AML firmware that you can flash with the USB Burning Tool should all else fails.

If you are connecting via Ethernet then there are options in using a custom ROM,  otherwise you're screwed !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...