Jump to content

Black Screen - No Recovery screen available

Recommended Posts

Black Screen - No Recovery screen available


I updated my MyGica AVT495Max TV box to the firmware that was listed on your MyGica website "update_MyGica_GTA_ATV495Max_enjoytv_7.1_20181009"

After the unit flashed the system it rebooted and all I get now is a blank/Black screen. I have tried pressing the reset button at the back until the blue light comes on and then releasing it and I have tried holding in the reset button for 15sec but still I am unable to get to a recovery screen. 

I managed to find another firmware through Syntech "update_MyGica_Syntech_ATV495Max_enjoytv_7.1_20190513" but I am now unable to flash anything as I cannot see anything.

Can anyone who has knowledge of how to rectify this please assist

Thank you

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...