Jump to content
Sign in to follow this  
multiton

MyGica iGrabber Nano Driver for Windows 10

Recommended Posts

Hi,

The drivers that came in the box with the product, as well as the ones listed here on your website, do not work in Windows 10.

When I open Device Manager it shows iGrabber Device, but it says:

"The drivers for this device are not installed. (Code 28)"

If I try to install them with Update Driver it says:

"A problem was encountered while attempting to add the driver to the store"

Device: MyGica iGrabber Nano

Operating System: Windows 10

Please help!

Share this post


Link to post
Share on other sites
Hi,

The drivers that came in the box with the product, as well as the ones listed here on your website, do not work in Windows 10.

When I open Device Manager it shows iGrabber Device, but it says:

"The drivers for this device are not installed. (Code 28)"

If I try to install them with Update Driver it says:

"A problem was encountered while attempting to add the driver to the store"

Device: MyGica iGrabber Nano

Operating System: Windows 10

Please help!

Are you able to run them in Win 7 or 8 compatibility mode?

Share this post


Link to post
Share on other sites

Well, since the installers work I didn't try compatibility mode. I don't know if you can set the compatibility mode for the drivers themselves.

The installers work without error, but the device is not recognized still after installing the drivers.

Then if you try to install the drivers using Windows Update and set to find the drivers on the CD, it finds them but says the message i pasted above.

I have tried to install the device on a virtual machine using Virtual Box and Windows XP SP3.

The drivers work on Windows XP, but the problem is the virtual machine freezes because "USB controller bandwidth exceeded" if I try to use the device.

Any ideas?

Share this post


Link to post
Share on other sites

Dear Justin,

I have exactly the same problem as multitone!

I expect the driver downloaded from the official site and dedicated for Windows 10 should work on Win 10 but it does not! why?

Does MyGica have a solution to that?

I do not think a solution is to become an expert in Win 10: I do not understand what do you exactly mean by suggesting to run it in a compatibility mode? I plug in the USB device and it shows an error. What is here to be run in a compatibility mode? Can you be more detail and specific in how to do it?

Thank you

  • Like 1

Share this post


Link to post
Share on other sites

Thank you Justin,

Thanks to you I learned a lot about Compatibility in Windows 10 and tried many combinations but, unfortunately - it does not work!

It recognizes the iGrabber gadget and looks OK in "Sound, video and game controllers" but shows as an error in "Other devices" Eventually - it does not capture anything.

Obviously, I will have to find some other product that works with Win10.

Goran

Share this post


Link to post
Share on other sites
Dear Justin, this driver doesn't solve the problem.

I tried everything with no avail, is there any way to make this device work on win 10 ?

The only other solution that has always worked for me is to run the driver in compatibility mode.

I find Windows 7 Compatibility mode works best.

Or uninstall the driver and reinstall the Windows 10 one I posted before.

Share this post


Link to post
Share on other sites

I registered for this forum just to post a solution to this problem. I also struggled to get the iGrabber to work on Windows 10, but finally solved it.

Windows 10 requires digitally signed drivers by default, and you must change this setting. You have to enable Advanced Startup options to do this.

After you have disabled certified driver signing, you can use the Device Manager to manually Update Driver, and choose Have Disk. Windows will prompt you with a warning about the driver's signature, but you can tell it to install anyway.

http://tivadj-tech.blogspot.in/2012/09/certificate-check-error-when-installing.html

Share this post


Link to post
Share on other sites
I registered for this forum just to post a solution to this problem. I also struggled to get the iGrabber to work on Windows 10, but finally solved it.

Windows 10 requires digitally signed drivers by default, and you must change this setting. You have to enable Advanced Startup options to do this.

After you have disabled certified driver signing, you can use the Device Manager to manually Update Driver, and choose Have Disk. Windows will prompt you with a warning about the driver's signature, but you can tell it to install anyway.

http://tivadj-tech.blogspot.in/2012/09/certificate-check-error-when-installing.html

Thanks for sharing this

  • Like 1

Share this post


Link to post
Share on other sites

I too have had no luck installing the Windows 10 driver. I downloaded the Windows 10 driver from the MyGica support section and I have tried running it as is, and in compatibility mode, and by disabling the driver signature certification and none of them work . I'm out of ideas.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×