Jump to content
PopGun

1900 Pro wont turn on with the remote

Recommended Posts

1900 Pro wont turn on with the remote

Hi guys,

I have had the unit for 3 weeks or so now, for some reason it wont turn on with the remote, or even turn off. This is the top left button on the remote
I can turn the unit on if I get up and hit the front button on the machine, then the remote works as normal, EXCEPT the top left button wont turn it off

 

Any help? I have tried to update, says all updated

 

Kind regards

Jared

Share this post


Link to post
Share on other sites

I found that when the unit is off, it will not turn on by using the left orange power button.

Press the mouse button, then press the power button, it works for me, to turn the unit on.

  • Confused 1

Share this post


Link to post
Share on other sites

Well there must be some kinda conspiracy going on here because I have exact same issue and it just occurred with teh same recently new unit ATV 1900? It was working great and love the speed and UI etc. Then suddenly just stopped turning unit on or off. Meanwhile once I boot unti by pressing ON button the remot works fine to operate device but still will not turn on or off.

I just tried this suggestion of clicking 'mouse button' (assuming you mean arrow in upper right corner of remote) and then orange power button and it did not work. I am stuck pushing button on unit right now. Hardly a feature anyone wants for a 'remote'. Any help as well would be nice.

Thanks.

ICE

Share this post


Link to post
Share on other sites

PS- Clearly this company has serious issues with their remotes with what I have read with other posts which means I will NOT recommend or buy another unit again unless the issue is easily resolvable. There are a ton of other comparable products on the market. Hope this gets resolved for the sake of the rest of the units working well and future sales for these people.

Share this post


Link to post
Share on other sites

Could be the batteries are or near dead 

Could be the remote needs to be paired with the receiver (part plugged into USB port)

Share this post


Link to post
Share on other sites

As stated above....

The remote operates the device without issue other than the powering on and off? Operation requires battery power and the device has only been in use for a couple months.  So how can the batteries be the issue for supplying power to the /On/Off button but not every other button on the remote that is functioning?

12 hours ago, admin said:

(part plugged into USB port)

Are you referring to the dongle? If so....please explain to me how my device works all other buttons for every single feature other than power on/off if that 'part plugged into USB port'/dongle is NOT paired? I will await your explanation before I reply or inquire further so we may establish some clarity here for all the other users who will/may experience this issue as well.

Thanks.

ICE

  • Sad 1

Share this post


Link to post
Share on other sites
56 minutes ago, admin said:

Do you want mail replacement or swap?

I'm not sure? Was hoping it was resolvable here. I don't want to go without my remote for any time as I live in a rural area on the water and rely on my net connection for all entrainment. So this device is IT! What is easiest? I still have the box and manual but not sure where I put receipt. I will defer to you for advice on how to proceed. What does each option entail? Obviously the most convenient in my situation.

Share this post


Link to post
Share on other sites
On 2/22/2018 at 2:18 PM, tricky said:

I found that when the unit is off, it will not turn on by using the left orange power button.

Press the mouse button, then press the power button, it works for me, to turn the unit on.

I also set up my Logitech Harmony to turn it on, definitely a problem with the remote. 

Share this post


Link to post
Share on other sites

Hi Guys,

Simple head over to mygica.tv/help and start a ticket. We have heard of some problems with out of the box 1900 pro remotes not working as intended. Get ahold of us and we will resolve this quickly.

 

 

Share this post


Link to post
Share on other sites

WTF is this BS??

YOU contact ME FFS!!!

******@yahoo.com

I went to your F'n site and its BS. WTF is an RMA?? Do you explain it??? Of Course NOT!? I'm sick of this BS. 150 ******* dollars for this POS and it works for 3 months and then ****** dies is unacceptable. FIX this PLEASE BE POLITE now before I go on a campaign and spam your PLEASE BE POLITE on every social media site online and bury you, HAD ENUFF! FO!!!!

Share this post


Link to post
Share on other sites

YOU BE POLITE and fix the trash you sold us. I am not chasing you around for this BULLSHHHHiT and have already been into BestBuy who sold your garbage and they are NOT impressed either. 

  • Confused 1

Share this post


Link to post
Share on other sites
13 hours ago, ICE® said:

YOU BE POLITE and fix the trash you sold us. I am not chasing you around for this BULLSHHHHiT and have already been into BestBuy who sold your garbage and they are NOT impressed either. 

The remote control turns the unit off and on by infrared technology and does not need to be paired - the keyboard functions through the USB antenna and needs to be paired for this function, does that help clarify things?

RMA is an acronym for Return Merchandise Authorization 

This way we can track the process of your warranty and keep you informed of the process.

Thank You

  • Haha 1

Share this post


Link to post
Share on other sites

The remotes on some of these units are failing just after the warranty period which is 60 days

Will not recommend these boxes

"

Warranty

  • 1 Year Warranty in Canada and USA repair facility. 60 day Remote warranty.
  • Authorized MyGica Dealers offer 1 year warranty Either by Repair or Exchange. Exchanges are only done if the unit cannot be repaired.

Share this post


Link to post
Share on other sites
On 3/5/2018 at 9:13 AM, tricky said:

The remotes on some of these units are failing just after the warranty period which is 60 days

Will not recommend these boxes

"

Warranty

  • 1 Year Warranty in Canada and USA repair facility. 60 day Remote warranty.
  • Authorized MyGica Dealers offer 1 year warranty Either by Repair or Exchange. Exchanges are only done if the unit cannot be repaired.

Well I'll tell you what, I'll do a whole mot more thna not recommmend any MYGica product. Word in the industry will be spread like wild fire. Oddly enough it just so happens my remote stopped working shortly after that period ended from DOP as well. For the admin geniuses that like to throw in acronym puzzles that means, Date of Purchase. It also sounds like I am not the only person with this issue and that this convenient failure (to the manufacturer) is very common. Could it be a scam these perps want to cash in on people having to BUY another remote at an unfair cost after the 60 days is up (and who TF puts a 60 day warranty on a NEW product?) when they have already paid for the remote which like most remotes should work for the life of the device?? I've NEVER had a remote fail on me before the device did, TV, stereo, fan, wall switch etc etc and NEVER EVER seen any corp put a 60 day warranty on anything but used/refurbished product.

If I do not get a replacement remote sent to me completely free of charge that WORKS well beyond the 60 day period I'll be contacting every business ethics practice in North America file claims against this company as well as create an online campaign on every social media network, Twitter, FB, Instagram, Google Store, all Kodi and apk related sites, condemning their products (ALL) as well as their business practices and we'll see how their sales practices and 60 day remote scam serves them then!!?? Nothing I hate more than some sleezy outfit trying to put one over on the consumer. If this is simply a poor manufacturing choice of supplier parts etc fine...we'll let them prove it through customer service to rectify the problem. If it shows signs of being anything more than an honest mistake they'll regret the day they made the decision to profit of some back end business practice which is a well known scam in the corporate industrial sector. Just not terribly well known to the consumer!

Lets see how this rolls and I hope each and every other consumer who feels they may have been taken advantage of or inconvenienced unfairly follows suit if it's proven this is unsavoury business.

Not impressed,

 

PS- I've already gone out and purchased a new ABOX 2GB 3 DDR-16GB unit to replace this unit which will be going into another room IF and when it is resolved and working properly without a CENT out of my pocket being spent.

Share this post


Link to post
Share on other sites
1 hour ago, ICE® said:

Well I'll tell you what, I'll do a whole mot more thna not recommmend any MYGica product. Word in the industry will be spread like wild fire. Oddly enough it just so happens my remote stopped working shortly after that period ended from DOP as well. For the admin geniuses that like to throw in acronym puzzles that means, Date of Purchase. It also sounds like I am not the only person with this issue and that this convenient failure (to the manufacturer) is very common. Could it be a scam these perps want to cash in on people having to BUY another remote at an unfair cost after the 60 days is up (and who TF puts a 60 day warranty on a NEW product?) when they have already paid for the remote which like most remotes should work for the life of the device?? I've NEVER had a remote fail on me before the device did, TV, stereo, fan, wall switch etc etc and NEVER EVER seen any corp put a 60 day warranty on anything but used/refurbished product.

If I do not get a replacement remote sent to me completely free of charge that WORKS well beyond the 60 day period I'll be contacting every business ethics practice in North America file claims against this company as well as create an online campaign on every social media network, Twitter, FB, Instagram, Google Store, all Kodi and apk related sites, condemning their products (ALL) as well as their business practices and we'll see how their sales practices and 60 day remote scam serves them then!!?? Nothing I hate more than some sleezy outfit trying to put one over on the consumer. If this is simply a poor manufacturing choice of supplier parts etc fine...we'll let them prove it through customer service to rectify the problem. If it shows signs of being anything more than an honest mistake they'll regret the day they made the decision to profit of some back end business practice which is a well known scam in the corporate industrial sector. Just not terribly well known to the consumer!

Lets see how this rolls and I hope each and every other consumer who feels they may have been taken advantage of or inconvenienced unfairly follows suit if it's proven this is unsavoury business.

Not impressed,

 

PS- I've already gone out and purchased a new ABOX 2GB 3 DDR-16GB unit to replace this unit which will be going into another room IF and when it is resolved and working properly without a CENT out of my pocket being spent.

ICE,

You are throwing around a lot of angry words here about our warranty with our remotes. Most manufacturers do not cover their remotes under any warranty. While you have been lucky with your other products that have not had remotes break, this is certainly not the case for a lot of people.

I ran your email through our warranty system and it turned up nothing.  So, you are here slinging all these problems with our company and you haven't even contacted us outside of this forum.

Furthermore, this post of yours and previous ones sound quite threatening. ie:

"I went to your F'n site and its BS. WTF is an RMA?? Do you explain it??? Of Course NOT!? I'm sick of this BS. 150 ******* dollars for this POS and it works for 3 months and then ****** dies is unacceptable. FIX this PLEASE BE POLITE now before I go on a campaign and spam your PLEASE BE POLITE on every social media site online and bury you, HAD ENUFF! FO!!!!"

For someone who seems to really want their system fixed, you have put in zero effort outside of bashing our company on our forums. For anyone who is taking the time to read through this nonsense, please consider reaching out to our warranty department like I have suggested to this gentleman several times and yet keeps just coming back to the forums and swearing at us.

Ice, Once again I will remind you to head over to our warranty site at mygica.tv/help

We take every ticket seriously and try to be flexible when we can. I can't promise the world, but a remote dying shortly after the 60 day warranty has passed should not be something that gets you pulling your hair out and we should be trying to resolve this with you. This can only be done through our warranty department.

 

 

Share this post


Link to post
Share on other sites

Listen...I BOUGHT this unit from a retailer...a HUGE retailer 'BEST BUY' and refuse to deal with any online BS for exactly this reason. I did not sign up for resolving my product purchases ONLINE! I bought a product and opened the box to find a BIG 'STOP' sign on the info included telling me I have to deal with some unknown face online rather than go back to to POP (Point of Purchase) and speak to the person face to face and have this issue resolved swiftly and effectively or they'd lose future business obviously...like we humans have done for ever. BUT NO...instead I am ambushed with your policy AFTER I buy it...take it home open it and THEN you tell me when it fails I HAVE TO DEAL WITH YOU??? Really? NO.

YEAH thats why I am pisssssed off. Not only because your product was costly (195.00 taxes inc. after I checked, and there are better out there at half the cost) but that it conveniently fails very shortly after the 60 day remote warranty and find out its happening with many people.  Beyond that there are 3 posters here who have all told you the EXACT same issue and what did you reply to ALL of us?  The same reply I have seen littered through many threads on this site....

"Could be the batteries are or near dead 

Could be the remote needs to be paired with the receiver (part plugged into USB port)"

What are we idiots? The one orange button not working on our units is a result of THAT?? Thanks for reading our posts that we at least took the time to put some thought into.

Popgun writes: 

I have had the unit for 3 weeks or so now, for some reason it wont turn on with the remote, or even turn off. This is the top left button on the remote
I can turn the unit on if I get up and hit the front button on the machine, then the remote works as normal, EXCEPT the top left button wont turn it off

Tricky writes:

I found that when the unit is off, it will not turn on by using the left orange power button.

Press the mouse button, then press the power button, it works for me, to turn the unit on.

ICE writes: 

I have exact same issue and it just occurred with the same recently new unit ATV 1900? It was working great and love the speed and UI etc. Then suddenly just stopped turning unit on or off. Meanwhile once I boot unit by pressing ON button the remote works fine to operate device but still will not turn on or off.

 

 

And you advise us of that because you REFUSE to read out efforts to get help by spending our time typing out the problem to YOU, which I will add again could have been managed by the in store rep I assumed I was dealing with when I purchased this product prior to the BIG RED STOP SIGN appearing inside my device box telling me, I HAD no choice to deal with YOU first?? I even went into Best Buy anyways just to avoid this BS. They are awaiting an update which I will surely provide in detail with a copy of this. And FYI to my knowledge they have not replaced any of your product on their shelves since the last unit was sold.

Why shouldn't I be angry because this is the typical crap online customer service many people get. Because reps like you don't do your job? But instead paste a standard reply into some box to put us off another day? Get real Rep!!! I did not sign up for or agree to deal with YOU when I bought this product although I am certainly aware much warranty is done after sale with the actual manufacturer. Had I known BB was selling this product and had no support for it I would not have bought it. It used to at least be a joint effort between retailer and manufacturer.

As for 'threatening'....PLEASE??!! If by being angry and making sure you know it and that I will do my very best to let others know about this neat little deal you have going on here of .....Sell Product.. Surprise people after you sell, that they can NOT take product back to store they bought it at...followed by the remote conveniently working for a period just a bit longer than what the warranty covers and you plan on charging us for a replacement after we spend time online finding support followed by then filing a 3 page ticket...followed by an online rep NOT even reading the actual issue online about what we are experiencing who then pastes one of the standard replies into the text of our thread...a reply I might add found all over this site?

Sure you call it what you want...I'll make damn sure all of this is everyone business by 'threatening' exposure ONLINE for the wonderful service and product support! You think any of us have time for this crap? I'd have a new remote and be quite happy if the store I bought this from replaced the remote and saved me and everyon from this garbage. The retail industry can NOT be replaced by this garbage.

NOT IMPRESSED

PS- DO YOUR JOB!!! Reply with relevant information when we first post....not check batteries or pairing that had absolutely SFA to do with any of our 3 issues posted. Issues I will add are all exactly the same. And FYI I did file A TICKET. Once again do your JOB!!!

 

 

Share this post


Link to post
Share on other sites
54 minutes ago, ICE® said:

Listen...I BOUGHT this unit from a retailer...a HUGE retailer 'BEST BUY' and refuse to deal with any online BS for exactly this reason. I did not sign up for resolving my product purchases ONLINE! I bought a product and opened the box to find a BIG 'STOP' sign on the info included telling me I have to deal with some unknown face online rather than go back to to POP (Point of Purchase) and speak to the person face to face and have this issue resolved swiftly and effectively or they'd lose future business obviously...like we humans have done for ever. BUT NO...instead I am ambushed with your policy AFTER I buy it...take it home open it and THEN you tell me when it fails I HAVE TO DEAL WITH YOU??? Really? NO.

YEAH thats why I am pisssssed off. Not only because your product was costly (195.00 taxes inc. after I checked, and there are better out there at half the cost) but that it conveniently fails very shortly after the 60 day remote warranty and find out its happening with many people.  Beyond that there are 3 posters here who have all told you the EXACT same issue and what did you reply to ALL of us?  The same reply I have seen littered through many threads on this site....

"Could be the batteries are or near dead 

Could be the remote needs to be paired with the receiver (part plugged into USB port)"

What are we idiots? The one orange button not working on our units is a result of THAT?? Thanks for reading our posts that we at least took the time to put some thought into.

Popgun writes: 

I have had the unit for 3 weeks or so now, for some reason it wont turn on with the remote, or even turn off. This is the top left button on the remote
I can turn the unit on if I get up and hit the front button on the machine, then the remote works as normal, EXCEPT the top left button wont turn it off

Tricky writes:

I found that when the unit is off, it will not turn on by using the left orange power button.

Press the mouse button, then press the power button, it works for me, to turn the unit on.

ICE writes: 

I have exact same issue and it just occurred with the same recently new unit ATV 1900? It was working great and love the speed and UI etc. Then suddenly just stopped turning unit on or off. Meanwhile once I boot unit by pressing ON button the remote works fine to operate device but still will not turn on or off.

 

 

And you advise us of that because you REFUSE to read out efforts to get help by spending our time typing out the problem to YOU, which I will add again could have been managed by the in store rep I assumed I was dealing with when I purchased this product prior to the BIG RED STOP SIGN appearing inside my device box telling me, I HAD no choice to deal with YOU first?? I even went into Best Buy anyways just to avoid this BS. They are awaiting an update which I will surely provide in detail with a copy of this. And FYI to my knowledge they have not replaced any of your product on their shelves since the last unit was sold.

Why shouldn't I be angry because this is the typical crap online customer service many people get. Because reps like you don't do your job? But instead paste a standard reply into some box to put us off another day? Get real Rep!!! I did not sign up for or agree to deal with YOU when I bought this product although I am certainly aware much warranty is done after sale with the actual manufacturer. Had I known BB was selling this product and had no support for it I would not have bought it. It used to at least be a joint effort between retailer and manufacturer.

As for 'threatening'....PLEASE??!! If by being angry and making sure you know it and that I will do my very best to let others know about this neat little deal you have going on here of .....Sell Product.. Surprise people after you sell, that they can NOT take product back to store they bought it at...followed by the remote conveniently working for a period just a bit longer than what the warranty covers and you plan on charging us for a replacement after we spend time online finding support followed by then filing a 3 page ticket...followed by an online rep NOT even reading the actual issue online about what we are experiencing who then pastes one of the standard replies into the text of our thread...a reply I might add found all over this site?

Sure you call it what you want...I'll make damn sure all of this is everyone business by 'threatening' exposure ONLINE for the wonderful service and product support! You think any of us have time for this crap? I'd have a new remote and be quite happy if the store I bought this from replaced the remote and saved me and everyon from this garbage. The retail industry can NOT be replaced by this garbage.

NOT IMPRESSED

PS- DO YOUR JOB!!! Reply with relevant information when we first post....not check batteries or pairing that had absolutely SFA to do with any of our 3 issues posted. Issues I will add are all exactly the same. And FYI I did file A TICKET. Once again do your JOB!!!

 

 

25

Ice,

You mention about wanting to deal with your point of sale and then express frustration as to why they cant do it. This is not under our control. Best buy has a return policy with a set amount of time. They do this in part to also try and sell you extended warranties to be able to handle it at their store. Again, nothing to do with us.

We put a "stop sign" in the package to try to encourage customers to contact us before returning. Returns affect business and cost a lot of money for companies. This is standard practice with all electronics. Literally, every single piece of electronic equipment you buy for your home comes with one of these. You say that you "can not" return the item to the store because of our stop sign being there? The stop sign does not force you to make any decision. Again, it is there as a hopeful reminder that we would prefer to try and rectify the problem during your return period rather than just exchanging or returning.

You pointed out other customer problems with this remote. We replied with more questions and suggestions because 7/10 times when the remote doesnt work, it is related to the IR sensor not being visible (which is why an orange button wont work, but the ones running through 2.3 ghz does) or the dongle that came with the remote is either not plugged in, is plugged into the TV or needs to be paired with the remote. We can't just assume the remote doesnt work for hardware issues. We need to try and fix these problems first.

While I agree that you are angry, what you were doing is definitely threatening us by telling us what you're going to do to take down our company and "bury us" with your hate campaign against us. 

I see that you started the ticket (while I was typing the reply to you) so I have to ask, why did you come back here and spew all this anger? The warranty ticket literally said "please upload a copy of your receipt and we will shoot you out a new remote". Even when we are doing exacrtly what you hope us to do, you are back here with another huge complaint.

What exactly are you hoping a company like ours does for you? We have a simple 5 minute process of claiming warranties and we don't give any hassle afterwords. We put a stop sign in to try and get you help for your system, we have forums to try and address issues from a combination of fans, techs, our employees as well as admins that do not work for us, but are here to try to assist with moderation of the forum and give any suggestions if they are comfortable doing so. 

 

You also mentioned that our tech gave you a "standard reply". But, it wasn't. It directly related to your issue and resolved the problem. 

This has been quite the tiring experience for both os uf I am sure. Why are you not just wanting to resolve this issue, easily and quickly without kicking up so much dust? You have spent at least ten times more effort in coming here to post about problems that are easily resolved. Again, the suggestions from others to how to potentially fix the remote, are needed before moving on to figure out what to do next.

Please tell me what else we can do for you. Within 20 minutes of your warranty claim being submitted, you received a reply resolving the issue at no expense to you. We are truely sorry that anyone has any issue with remotes. We are working hard to make sure that people are happy with the money they spent. If this problem were as big as you make it out to be, our reviews would all be 1 star very quickly on all the major sites. This simply isnt the case. With full disclosure, we have now had 12 reports of this remote failing over the last several months out of hundreds of thousands that are on the market. I would like to add my personal opinion that while this is the highest failure rate of any of our remotes, it is actually almost non existant. 

We are open to resonable suggestions of how to improve our system. 

 

 

 

Share this post


Link to post
Share on other sites

Look...I've committed enough time to this already. I don't agree with most of what you've said above and certainly will not agree that a RANT about the 'standard reply' which is exactly what it was and what set me off after being to the store and them telling me I had to deal with you instead of them...constitutes you accusing me of a 'hate campaign'.. You're in business, customers are going to be irate when you slight them. Deal with it. 

THIS statement is false...  "You also mentioned that our tech gave you a "standard reply". But, it wasn't. It directly related to your issue and resolved the problem."

NO...it did NOT resolve MY problem or any of the other posters. I am not here to  argue with you. I am happy to provide an apology for the RANT providing you do the same for what caused it... and that remains and is not up for debate in my mind... Batteries and Pairing do NOT resolve the specific problem myself and the two other posters came here for help about. ADMIT when you are wrong! Its what good business practice is all about.

As for your accusations about timing of where I am and when I post...you are in between your two sites and I was directed to another site to resolve the issue which again is a pain. Here again it does not serve you well because while I am replying over there you are posting over here. You want advice on how to better serve...There it is! Eliminate directing people to multiple sites and do it all on one site and  Secondly and this one is rather KEY...give them the appropriate advice when they ask.

Now I am done with this. You may delete anything I have said here and with any luck at all...the dealings with you over there on YOUR OTHER site will go swimmingly and this can be put to bed. Your uploaded receipt request will arrive as soon as I can STOP replying HERE!

Thanks for your help...or attempt at help until now. I will be at your other site now for the remainder of this issue.

ICE

Share this post


Link to post
Share on other sites

Ice,

 

Forums on all company websites are different than their warranty departments.  You must separate the two. You don't go to a tech forum to get repair work. The forums will always say, contact the warranty department when actual repair or replacement is needed.

The comment about the tech giving a standard reply, I assumed you meant in our warranty ticket system. If you are referring to the reply from an admin, he is not a tech, he is a forum administrator who goes above and beyond in an attempt to assist others during off hours when not as much attention is being given in the forums. Also, although he didn;t give instructions on how to pair the dongle, he did make the right suggestion. The instructions are easily located anywhere on this forum or by simply typing into google, "pair mygica remote". The first page shows you how.

"You may delete anything I have said here". While others may be excited to delete this from a forum history, I think it stands up to show that we are not only engaged with our forum users but that we serve to rectify issues as best we can and give flexibility when its called for. Simply put, we are not some evil corporation out to steal your money. We are a business that believes that we can capitalize on a market that leaves a lot to be desired with customer service, warranties and IMO the most important thing, safety certified power supplies and licensed hardware. 

 

Share this post


Link to post
Share on other sites

Got to jump in on this.

My remote wasn't turning the 1900 pro on but would function normally when on.

Because I had programmed my Harmony remote to turn on the unit, I figured the remote to be the problem, in a way it was.

I had changed batteries and it still wouldn't turn on the unit

However I decided to google how to test the infrared function on a remote to see if it was working or not, I came up with this

https://www.techhive.com/article/2090126/use-your-smartphone-to-check-your-remote-control-batteries.html

There was a flicker of light showing in the camera when the orange button was pressed..... hmmmm.... was it just not strong enough to turn the unit on?

fresh batteries installed again, obviously the fresh batteries I had put in previously were not fresh so to speak.

The remote is once again turning on the unit.

Google to the rescue once again.

  • Like 1

Share this post


Link to post
Share on other sites
16 hours ago, tricky said:

Got to jump in on this.

My remote wasn't turning the 1900 pro on but would function normally when on.

Because I had programmed my Harmony remote to turn on the unit, I figured the remote to be the problem, in a way it was.

I had changed batteries and it still wouldn't turn on the unit

However I decided to google how to test the infrared function on a remote to see if it was working or not, I came up with this

https://www.techhive.com/article/2090126/use-your-smartphone-to-check-your-remote-control-batteries.html

There was a flicker of light showing in the camera when the orange button was pressed..... hmmmm.... was it just not strong enough to turn the unit on?

fresh batteries installed again, obviously the fresh batteries I had put in previously were not fresh so to speak.

The remote is once again turning on the unit.

Google to the rescue once again.

I really like this "trick". I had heard about this some time ago and forgot about it. I think we will add this to the list of things to try before advising the customer to send it in, or go through a warranty replacement.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×