Jump to content

MyGica_1900AC/1800/582/380_Android_5.1_20170612 1.0.0

   (7 reviews)

1 Screenshot

About This File

Here is the Beta Firmware to upgrade your ATV 1900AC/1800 series/582/380 to Android 5.1

You can install this using an SD Card or USB drive and the upgrade app listed in the settings area.

This does not require manually pressing the reset button.

Just extract the IMG file from the zip folder and move it to a USB drive or SD Card that is formatted to FAT32.

**PLEASE NOTE THIS WILL FACTORY RESET YOUR DEVICE**

 

Change Logs:

1. Updated to KODI 17.3
2. Updated Google Play Services
3. Faster Performance 
4. Fixed Mac Address changing 
5. Turned off click sounds when browsing through the Home Screen + Android Settings
6. Fixed Screensaver issue when watching a video
7. Improved video playback
8. Improved standby issues as best we could. There is not much more we can do about this issue

 

 

 




User Feedback

Create an account or sign in to leave a review

You need to be a member in order to leave a review

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Justin

Report ·

   2 of 2 members found this review helpful 2 / 2 members

We are just going to fix the Wifi connection issue after coming out of standby.

We should be able to send this as an OTA update.

As for another full firmware release
You probably won't see it, this is the most stable version of 5.1 we could make to date.  That is why its been released as BETA only.
There has not been an update to 5.1 from Amlogic for the S812/S802/S805 chipsets in almost 2 years, and they have told us there wont be another one again as they have stopped support.

  • Like 1

Share this review


Link to review
dunn

Report ·

   1 of 1 member found this review helpful 1 / 1 member

I have no problem install the beta version on my ATV1800E. This beta version is very good and stable. The only problem is wifi. Wifi can't auto connect after wake up from stand by. I have to reboot every time in order to use. Other than that everything seems to be good.

Share this review


Link to review
dxn131

Report ·

   1 of 1 member found this review helpful 1 / 1 member

Thanks Justin. My apology for exposing the third party link in my post recently. Other than what was mentioned in my previous post, I am satisfied with the new  beta version installed on my 1800E. Everything works great. However, there is one observe which brought to my attention is that the remote controller (which came with myGica1800E) does not seem to response well enough. But, I can leave with that until a stable version coming out.

Do you have an estimate as when a stable 5.11 version will be available for 1800E?

Regards

Share this review


Link to review
YVRNJB

Report ·

   2 of 3 members found this review helpful 2 / 3 members

I installed this on my 1800. The install went fine but now it freezes ALL the time and I have to unplug the power from the box to get it working again.

Also, I cannot get wifi to work, only ethernet works.

Share this review


Link to review
MacktheKnife

Report ·

  

Installed beta firmware 5.1 upgrade which also loaded Kodi 17.3 to my atv 1900ac box - browser, Netflix and YouTube all connect to WiFi but Kodi will not - how do I fix this?

Share this review


Link to review
Martin Stander

Report ·

  

Been using this version on both my 582s. There are quite a few issues I have picked up, and it is quite irritating.

  1.  The "Date and Time" settings are buggy. Sometimes, when selected for Auto, then it puts the date as 1970. Switch to manual and it is a PITA to get it set properly. Then, for no reason at all, it works on Auto again. Apps does not work properly if the date and time is not correct.
  2. Browser app would open, then try and do something, and then just closes itself, without you getting the time to input search criteria. Been trying to update Kodi to 17.4, but can not keep the browser open for long enough.
  3. The same can be said for Playstore. Just closes itself randomly.
  4. The worst part of this update is that streaming is a hit and miss affair. I can be in an add-on and stream fine one night. Next night I want to watch another movie, and movie starts without sound, or no picture while time counts up. No apparent explanation why it happens. Only thing to do is reboot Mygica. Then the same movie, same stream, works fine. Initially I thought my fibre line was wonky, but speedtests showed all fine. This is maybe the worst part of the update.
  5. Last thing, sometimes when watching an episode, at the end I press STOP and the the back button once, then Mygica goes totally out of add-on. Also quite irritating.

 

I personally don't think this version is stable at all. Needs lots of work

Share this review


Link to review
nonothing

Report ·

  

I had to install it a second time on my 1800e using forced manual method because the automatic update option worked until I rebooted and then it froze on the bootup screen.  Everything is working perfectly but WiFi is a must fix for this release.  I need wifi for my other units.  When do you think the wifi will be fixed?

Share this review


Link to review
×