Jump to content
joels

Mygica South Africa. Wow!

Recommended Posts

Mygica South Africa. Wow!

I don't compliment easily but mygica South Africa (syntech) sorted out my 495 max. They replaced it with a new one. It wasn't the upgrade that bricked it. It was hardware failure. The box obviously had out the box issues. The new box works perfectly. Even chromecast. Fantastic!

They advised me NOT to upgrade to Pie until the firmware is tested thoroughly by themselves. They don't even have a copy yet of Pie. I'll only do that once its on their site. Mygica.co.za.

Share this post


Link to post
Share on other sites
On 5/17/2019 at 4:46 PM, joels said:

Mygica South Africa. Wow!

I don't compliment easily but mygica South Africa (syntech) sorted out my 495 max. They replaced it with a new one. It wasn't the upgrade that bricked it. It was hardware failure. The box obviously had out the box issues. The new box works perfectly. Even chromecast. Fantastic!

They advised me NOT to upgrade to Pie until the firmware is tested thoroughly by themselves. They don't even have a copy yet of Pie. I'll only do that once its on their site. Mygica.co.za.

Great to hear

Thanks for sharing

Share this post


Link to post
Share on other sites
1 hour ago, jdido87 said:

When is Pie coming or how can I revert back to the original firmware to at least get Netflix working in SD. I don't think the USB burning tool works

The problem is not the USB burning tool software because I used it in the past with another device, the problem is the image file created by Geniatech not loading inside the program.

Share this post


Link to post
Share on other sites
9 minutes ago, delacosta78 said:

The problem is not the USB burning tool software because I used it in the past with another device, the problem is the image file created by Geniatech not loading inside the program.

See:

https://www.mygica.co.za/faq/

It explains what to do. Looks like you just update using the original firmware. There's a link to it on the page

Edited by joels

Share this post


Link to post
Share on other sites
16 hours ago, delacosta78 said:

Oh the same firmware is posted in the FAQ link, OK, I didn't noticed it, sorry.

The impression I get is that you just run an upgrade with the old firmware.

Share this post


Link to post
Share on other sites

I get a error trying to rollback to the original firmware following the same process advanced when installing the beta version with Netflix. Any ideas how I can go back to the original firmware? 

Share this post


Link to post
Share on other sites
3 hours ago, jdido87 said:

I get a error trying to rollback to the original firmware following the same process advanced when installing the beta version with Netflix. Any ideas how I can go back to the original firmware? 

That' the problem, neither both options are working, Geniatech/MyGica must address this issues ASAP.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...